1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 32bit AU Bridge Crashes

Discussion in 'Logic 9' started by Atlas, Oct 27, 2012.

  1. Atlas

    Atlas Senior member

    32bit AU Bridge Crashes does happen to me on a regular basis.
    The frequency appears totally random, unrelated to the Mac being idle or in use, whatever if any other apps are also running, regardless of the project type or size.
    And to add to the mystery, since I installed v.9.1.8, the "32bit AU Bridge quit unexpectedly" even when there are no 32bit plugins instantiated!?!
    BTW, this problem also occurs in MainStage...

    Anyone else has that perduring problem?
    Any solution found yet, besides booting Logic in 32bit?
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

    I suspect that ultimately, the solution to this will be to be able to remove the 32 bit bridge entirely. While I am not any sort of programmer, my understanding is that a bit bridge by it's nature is an imperfect solution, a hack of sorts, and in a perfect world we would work purely in a 16, or 32, or 64, or someday even a 128 bit environment without the necessity to mix. It is almost 3 years since Logic 9.1 gave us the ability to access the vast amounts of memory that 64 bit allows. Back then, 64 bit plug-ins were almost non-existent, and while it has taken many developers a long time to deal with this, at this stage those that will have done so, those that haven't won't, or deserve to be villified for taking so much time. It was developed to facilitate the transformation from 32 to 64 bit. There has been plenty of time for that. I don't expect the 32 bit bridge to be around forever and suspect that Apple will be glad when they can at some stage remove it from a future version of logic.

    In the meantime all you can do is send crash reports to Apple's logic feedback in the hope that they may try to improve things, but also keep pestering those AU developers who still haven't gotten the finger out!

    kind regards

    Mark
     
  4. Atlas

    Atlas Senior member

    Thanx for your reply!
    I did already all you suggested to no avail so far...
    I am turning to this thread in the hope of possible unforeseen enlightenment...
    However, last week I received an advertisement e-mail from AAS (which have not updated their plugins yet), teasing me about their Lounge Lizard EP being ported to 64bit finally; adding that some more good news would be also coming out soon. Since their plugins are the only ones I still have in 32bit, I keep (all of) my fingers crossed!

    On the other had, my main concern is that recently, after updating Logic to 9.1.8, that "32bit AU Bridge crashing problem" started to occur even though I had no 32bit plugins instantiated at all!?

    BTW, you don't mention if you had experienced similar problem?
     
  5. Markdvc

    Markdvc Administrator Staff Member

    Definitely worth sending the crash logs to Apple, along with with a description of what happened.

    I have experienced 32 bit bridge crashes, but haven't noticed anything worse with 9.1.8 though. I note you are on 10.6.8, I am running 10.7.5 on my Mac Pro. No idea whether that is relevant.

    kind regards

    Mark
     
  6. Atlas

    Atlas Senior member

    I did not update yet to ML, as it still has too many (reported) issues, and I have only one system to rely on...
     

Share This Page