1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 9.1.8, OSX 10.9.2, random crashing help?

Discussion in 'Logic 9' started by cl516, Mar 28, 2014.

  1. cl516

    cl516 New Member

    Hi there, I'm getting random crashes with Logic 9.1.8, on OSX 10.9.2,
    Mac Pro 3,1. The crashes have no pattern, and I can even get work done.
    But they do occur randomly, almost related to nothing: can be as simple as clicking on something, or just shifting bars forward, etc.

    Anyone experience this?
    Is it OK to post crash logs on here?

    thanks
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

    Hi there, welcome to the LUG.

    It is OK to post crash logs, but please don't paste them directly into a forum post, rather, save the log as a text file, and attach that to a post. There are a couple of reasons for this: Firstly, the crash log may (probably will) exceed the number of characters that can be posted directly in the forum. Secondly, they make a thread extremely long and unwieldy to scroll through. Finally, not everyone will be able to make sense of a crash log. Those that can will be able to open the attachment and maybe help.

    What you definitely should do is provide system details.

    kind regards

    Mark
     
  4. Definitely post your system details. I'm on the same Mac Pro with the same OS, and I've had zero crashes in Logic 9 or X, even while running several other apps alongside.

    Also: Assuming your system runs well otherwise, the issue may come down to a plug-in. Have you added anything recently?
     
  5. cl516

    cl516 New Member

    mac pro 3,1
    8 cores
    10.9.2
    logic 9.1.8
    10 GB ram

    ok here's what i did notice so far though. some forums i searched said to delete user preferences, so i did that. still crashed.

    then someone said delete all the ableton live stuff, and i had a bunch of legit but older versions, so i deleted those and that seemed to help a bit.

    i just don't understand why the crashes always seem to happen during insignificant event like graphical stuff or clicking the mouse.

    i do have dual displays, and recently upgraded to SSD's. i know i'm forgetting something else, will post again when i remember, sorry...
     
  6. cl516

    cl516 New Member

    i tried deleting the prokit.framework under library/system/private frameworks, but that literally broke Logic and it wouldn't startup, so i had to retrieve it from time machine...
     
  7. robitaille59

    robitaille59 New Member

    Is it possible that you are running Logic in 32 bit mode?

    I'm not sure if that's even possible with 10.9.2 but I'm using 10.7.5 and I had to make an adjustment to get my Logic to run in 64 bit.

    Of course theoretically that shouldn't make it crash, that should only make it slower but you should check that out.
     
  8. cl516

    cl516 New Member

    FWIW, yes my 32bit mode Logic has been running OK these days.
    What was the difference? Ever since I went all-out deleting preferences, that seemed to help. I think what did the trick was removing every last item related to Ableton Live / Rewire. I can't explain it, but no crashes since... fingers crossed.
     
  9. robitaille59

    robitaille59 New Member

    Here's a bit of information I wrote regarding your post before you said the crashing stopped. I'm going to go ahead and post it in case it helps our another member of the LUG.



    You have to have a 64 bit OS to access any RAM that exceeds 2 GB. You stated that you have 10 GBs of RAM so you'll want to be running the OS in 64bit.

    I don't know if the newer versions of the Mac OS default to 64 bit or not but when I was on 10.6.8 you had to hold down the 6 and the 4 key during boot for 64 bit and the 3 and 2 for 32 bit.

    To be sure you should make sure your OS is using the 64bit kernel.

    Here's how to do that:

    http://www.wikihow.com/Determine-if-You're-running-the-32-Bit-or-64-Bit-Kernel-in-Mac-oSX

    Now that the OS is definitely 64 bit you will want to run Logic in 64 bit mode. This will allow the application access to all of your RAM.

    Here's how to do that:

    http://www.logic-cafe.com/lc/index.php/running-logic-pro-in-64-bit-mode

    The last thing I would be concerned about in regards to the stability of your system is the fact that you said you have 10GB of RAM.

    Usually a computer will have 2GB, 4GB, 8GB, 16GB or 32GB because the sticks of RAM are paired.

    You said you have 10GB...so is that two 4GB sticks and one 2GB? That would mean you added that RAM yourself and I would take the 2GB stick out to see if your system is more stable. If you want more than 8GB of RAM I suggest going to OWC and seeing if you can get two 8GB sticks to give you 16 and just leave out the 2GB stick
     

Share This Page