1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Advice: studio upgrade LP8/Eastwest Play/Saffire LE/new Quadcore

Discussion in 'Logic 8' started by theprawn, Oct 17, 2009.

  1. theprawn

    theprawn New Member

    All, we are about to upgrade studio 1 for a job and time will be of the essence so I would really appreciate any advice on OS and LP updates, drivers and general compatibility.

    We will be moving from a dual G5 2.0Ghz running 10.4.11 and LP8.0.

    Half the job is about lush, epic Eastern orchestration so we will be wanting to use the Eastwest instruments, especially Silk & other Eastern ones, for realistic performances - plus half the job is about sound design so we'll also be acquiring Komplete 6 and hoping to make use of Reaktor & Massive.

    Current plan is to stay on LP8 and get a new Quad core 2.66Ghz so I guess we will go to 10.5 or 10.6. If you would care to share your experiences and recommendations on the most stable operating system, LP8 update, and RAM combination, that would be great. We are running a Focusrite Saffire LE on Firewire which I have not been that happy about stability-wise to date (I would much prefer PCI) but we may have to stick with it. I hope we'll be able to run 4Tb of storage internally across the 4 bays in some sort of RAID configuration too, but again this will be a first so - grateful for tips.

    Also, is there anything you think we should know about Play or NI compatibility/processor-hogging? And can we improve stability by installing apps and plugins in a specific order? DV are offering to install the Eastwest stuff before delivery which would be a huge time-saver but I don't want to do that if it'll be screwed up by installing LP8 afterwards!

    We do lots of work to video (including this job) and we also often run quite a lot of tracks, perhaps 20-30 audio and 20 software instruments in the biggest cases. Also we tend to have a lot of fluid tempo changes in some of our work. On the G5 we're certainly used to maxing stuff out really quickly so anything we can do to improve workflow will be a great relief.

    OK - thanks for reading, it's much appreciated. peaceout!:hippy:

  3. yore

    yore Member

    I went form G5 to two quad core Mac Pro last summer. Best performance from RAM is to install in sets of threes. Also with new computer it is always the best practice to install everything from scratch. I also took the advantage of East/West sale at the time and bought their libraries. The biggest obstacle now is not the CPU performance but rather the 32-bit RAM space limit. While I would have plenty of CPU left the memory addresses are used earlier. I doubt that I will get everything out of this Mac until all the stuff (plug ins, audio drivers and Logic) are truly 64 bit. Of course by then my whole audio configuration goes up in the smoke so for me it will be a very bitter sweet update.
  4. yore

    yore Member

    Oh forgot that I'm using Logic 9 but with Leopard 10.5.8. Apparently many installers have problems in Snow Leopard. So although it's been on my table for many weeks I will not be installing it for a long long time.
  5. theprawn

    theprawn New Member


    thanks man, really useful. I will try to avoid 10.6!!
  6. Nuevo

    Nuevo Member

    I recently upgraded also...but found a quad w/10,5,6 updated that to 10.5.8..LP9.0...everything is working as far as plugins so far except East West PLAY..Im using MOR but will need to upgrade my StormDrum and RA...I loaded MOR, but the strange thing is after I hit a note say 3 to 5 times, the note disappears...Ive checked the streaming, still waiting to hear from EW support which for some reason is really slow about this...bumped PLAY to the nec latest version....the only thing I think may be that I put the sample lib on a 2nd drive..Im just guessing, but somethings not right and MOR is unusable at this point..I have the sample lib on the G5 on a 2nd drive and it works ok... mabey I shouldve installed everything to HD1 then moved the sample libs to HD2, but Im only guessing now..I wonder if theres anyway I could allocate more ram to this.... I have 8GB in the quad....anyone have this lib working Id appt some advice.
  7. theprawn

    theprawn New Member

    Massive fingers crossed time. New Quad comes tomorrow with Snow Leopard and I have no OS10.5 to revert to :D

    No Logic 9 either but hopefully 8 will be just dandy.

    I fear I will be tearing my hair out over the Focusrite drivers though.

    Then in a few days, EWQL Silk & Complete Composers, so I am mildly quaking about Play compatibility. Deep breath.

    We shall see!

  8. Nuevo

    Nuevo Member

    Good luck w/the PLAY..I ended up completely uninstalling PLAY/MOR due to the problems I was having w/dropouts...note would play 6 or 7 times, then drop out..unusable..I do have EW Sym Orchestra..all of EW stuff uses PLAY...Im going to install that b4 I try MOR again..mabey w/PLAY already installed and updated I will have fewer problems..it works better on my G5... EW tech crew are really great offering ideas on how to make it work..some people have no problems w/it, so mabey I did something incorrect on the install..nonetheless, I really thought the PLAY stuff would run much better on the quad...

    We shall see...
  9. theprawn

    theprawn New Member

    Yes I'm hoping new machine and clean installs with separate drives for samples will make it work.
  10. theprawn

    theprawn New Member

    This is interesting - can you explain more?

Share This Page