1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Akai MPK88 and Logic

Discussion in 'Logic 9' started by Benbean23, Oct 20, 2012.

  1. Benbean23

    Benbean23 New Member

    I've been putting a lot of time and energy in to something as simple as getting my sustain pedal to work in Logic. It works in Garageband, but in Logic it acts as a toggle switch to arm/disarm record on the track. I feel like I've tried everything. First and foremost, the pedal is edited to 64 and momentary on the keyboard.
    I tried:
    initializing key commands
    initializing everything else

    Could it be something in Controller Assignments?

    Aside for this issue, I'm hoping I can get an opinion...

    Would I be better off returning the Akai and getting something else?
    Would a M-audio Oxygen 88, for instance, be easier and work more effortlessly than the Akai?
    Any advice is appreciated! Thanks so much.
     
  2.  
  3. Atlas

    Atlas Senior member

    Normally your sustain pedal is connected in the right jack to your MPK88.
    Make sure that jack is configured to send cc64; check in the Logic MIDI-IN readout (in the Transport display), that is what is actually received when you actuate your pedal.
    If you DONT see cc64 there, this could only mean that Logic is not receiving that.
    Make sure that you have installed the proper drivers for your MPK.
    Did you check the Akai download support page lately?
     
  4. Eli

    Eli Senior member

    Hi Ben,

    Just a shot in the dark here, but check out your control surface setup in the preferences menu. See if there is any control surface setup there. If there is, select the icon and delete it. This may resolve things.
     

Share This Page