1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Annoyance with Audio Midi Setup and ports in Logic

Discussion in 'Logic 8' started by mattrixx, Apr 7, 2009.

  1. mattrixx

    mattrixx Senior member

    Hi all,
    Just wondering if anyone else is annoyed with the way midi ports are addressed in Logic, in relation to Midi control of various commands in Logic.

    A simple case in point for me is when I have my Virus TI turned on, I have one set up of logic_cs preferences and another for when my Virus TI is turned off. The only around this is to double up on the settings within the controller assignments window.

    So you buy a new piece of external midi kit and all of a sudden all your previously setup controllers stop working..... So you have to re-enter them all again one by one.
    Sometimes adding or removing a device, doesn't affect it at all... Just depends on the order of the ports on the physical input (in the environment).

    If you could rename the ports in the Audio Midi Setup and change the order in which they appear, you might have some control over the random nature of the problem.

    Has anyone else run into this, or am I the only bothering with it?

    Matt
     
  2.  
  3. Peter Ostry

    Peter Ostry Administrator Staff Member

    Common problem.

    The situation is better when you have a large MIDI interface instead of using the MIDI inputs of several devices. Of course not possible if your MIDI gear works via USB.

    If you change your setup very often you can try to run MidiPipe in front of Logic, with virtual ports and orignal ports hidden. Not very comfortable and one application more to run and to look after ...
     
  4. mattrixx

    mattrixx Senior member

    Yes, I have worked with the MidiPipe method before and unfortunately, I do have a lot of USB kit too.
    It seems strange that there is no provision for customisation within AMS.
     

Share This Page