Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Another Logic pro x wackadoodle anomoly

Discussion in 'Logic Pro X' started by madelefant, Jun 6, 2016.

  1. madelefant

    madelefant Senior member

    So sometimes I like to do in a song what I call a "Jump cut." So say your are chugging along at 4/4 and there is a point where you want to emphasize a transition or change or after a pause. I like to do what I call a jump cut. So this would be where the beginning of the next passage starts one beat early. So instead of 4 beats, it comes in at 3, but then it continues on at 4/4. So heres what happens in Logic Pro X. You try to put in this bar that has one less beat, and no matter what you do, it is the same temporal duration as that of a 4/4 bar but the metronome just clicks 3 times (if you set it to 3/4). You cant set it to 3/3. What it should do, if at the same tempo, I change it to 3 beats per bar, then it should be one beat less, at the same tempo. Like I said, no matter what signature I put in, the actual time for the measure is the same. I could only fix it by setting the tempo to the same speed as what would be 3 beats of 4/4. Just nuts.

    Mike
     
  2.  
  3. Pete Thomas

    Pete Thomas Administrator Staff Member

    It is indeed nuts.

    This is extremely odd, not normal. people use time signature changes all the time with no known issues like that.

    Are you saying that when you insert a 3/4 bar, Logic somehow actually changes the tempo? ie it makes those three beats sound like a minim (1/2 note) triplet?
     
  4. madelefant

    madelefant Senior member

    Heres the issue. If you are at 120 beats per minute and 4/4 time, each beat is 30 bpm. So lets say you want to have a bar, with 3 beats of 30 bbm per or 90 in total or, 3/4's of 120 or 3/4'ths of 4/4 however you express it. So after the bar, you resume 4/4. How do you do it? I tried just a about everything. What it did, was if I put in a bar of 3/4 (3 beats) that duration was still 120 bpm. It took exactly the same duration as the 4/4 bars.

    Mike
     
  5. Pete Thomas

    Pete Thomas Administrator Staff Member

    No, if you are at 120bpm, each beat is at 120bpm. Changing time signature has nothing to do with changing tempo, so if the tempo is changing it's either operator error or a very strange bug, both of which seem unlikely though so tis is a bit puzzling

    Maybe you are confusing beats per minute with bars per minute?

    If I want to change from 4/4 to a 3/4 bar and back I just put a 3/4 bar followed by a 4/4 bar. When i do that, the tempo doesn't change.
     
    Last edited: Jun 6, 2016
  6. volovicg

    volovicg Senior member

    It would be good to get a clearer picture of what you want to achieve by providing a visual example with a score or or if its audio where you want "what" and "when" to start. There is some confusion for me in understanding your description ( I am sure it is my fault) but let's see if we can work through it.

    1/ Peter is correct.... in that if you want 4 beats in a measured followed by 3 beats in a measure - setting the time signature as such ( where one follows the other) will not affect the tempo and the beats per minute remain constant. The Metronome will click uniformity through the time signature change - you should hear no variation in tempo. ( if that is why you want)

    2/ Make sure you are not using beat grouping - if you are - this will affect the metronome. If you need beat groupings for visual reasons but don't want it to affect the click - then uncheck "group" checkbox in the metronome settings dialogue.

    3/ Time signatures can only be added on bar boundaries complying with the time signatures "beats per measure". Musically you can't change the time signature in the middle of a bar. This is what you are trying to do as far as I can tell and it cannot be done. If you want more beats or less beats in the measure after the 4/4 you must make the entire measure the new time signature. So if I want 3 beats in the next measure - it should be 3/4 time. If I want 5 beats then 5/4 etc etc... to the best of my knowledge ( which doesn't say much) in western music all time signature changes occur on whole bars. So one more example.. if you are in 4/4 and you want to go to 3/4 time after you play 2 beats of the 4/4 time. You would need 4/4 followed by 2/4 followed by 3/4......(or you could do 6/4 followed by 3/4). Either way you have to comply with completing the previous measure's time signature before changing to a new one.

    again - I don't know if any of the above is helpful - but maybe you an extract a possible solution to your issue as a result.
     
  7. sonnykeyes

    sonnykeyes Senior member

    OK I'm going to take a wild guess here, and I could be totally wrong, so ignore me if this isn't it. If you're using loops that are in 4/4 time and you insert a bar of 3/4 in your arrangement, the loops will still want to finish out their four beats, so you won't get the 'jump cut' you're looking for. The solution is to insert the bar of 3/4 into your arrangement, then place the playhead at Beat 1 of the first bar after the 3/4 bar and CUT all your loops, then delete the last beat that you've now snipped off each loop. Then copy your loops so they start at the new downbeat you just cut on, and keep going in 4/4.

    If this isn't the problem you're having, I'm not sure what will help.
     
  8. bayswater

    bayswater Senior member

    Bizzare. Here's a simple project with nothing but two signature changes. It starts in 4/4. In bar 2 it changes to 3/4. In bar 3 it changes back to 4/4 It works as expected on my setup. Does it work on yours?
     

    Attached Files:

  9. madelefant

    madelefant Senior member

    I did a blank project and did just the same and it works. I'm quite sure the issue is an interaction with already recorded audio and flex analysis. I believe once you have done flex analysis, even after turning it off, it sometimes responds or has anomalies that are bug interactions with flex. In some cases I've noticed that just by turning on Flex, with no edits on a track, or any quantization it will change audio playback. This was happening within the same project. After turning on flex some portions would develop what I call warbling. The audio gets sort of messed up and blurred. When this happened, I turned the flex off, and then back on again for the track it was occurring on, and it went away.

    I think they are inter-related.
     
  10. madelefant

    madelefant Senior member

    I figured this out. This screen capture posted on youtube, demonstrates the issue.

     
  11. Pete Thomas

    Pete Thomas Administrator Staff Member

    Your video however doesn't show the problem. neither flex nor follow tempo should cause tempo changes.

    Something appears to be wrong with that but it's not a bug I can reproduce.

    What happens if you start a simple project from scratch (from a new project not a saved template)
     
  12. madelefant

    madelefant Senior member

    Well making those changes did solve the problem regardless of whether it should (i.e. that flex or follow tempo shouldn't cause tempo changes). I made a post explaining that when making a blank project and then inserting signature changes it works fine. But I also explained that sometimes, when activating flex, but with no quantization or edits made using flex, some of the audio will develop what is similar to flex adaptations that distort the audio in a non musical way. In that case, turning it off, and back on again has solved it.
     
  13. madelefant

    madelefant Senior member

    Thanks. They are all just regular audio I recorded. Not made into loops. I solved the problem. See posts I made for answer. I did realize I had 10.2.1 on that machine and not 10.2.2.
     

Share This Page