1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Assign Key Command to Control Surface

Discussion in 'Logic Pro X' started by nautonnier, May 3, 2015.

  1. nautonnier

    nautonnier New Member

    Hello all,

    I'm editing the stock LogicPad template in TouchOSC. I want to combine the 'Play' and 'Stop' buttons into one button to emulate what I like the space bar to do which is to "Play or Stop and Go to Last Locate Position." So this is what I think the steps should be:

    1) Either on a page or a "No Mode" mode, add an assignment
    2) Name the assignment (apparently if you don't do this first you can never add a name--you can edit an existing name but not add one)
    3) In the "Class" dropdown, select "Key Command"
    4) Enter (or select?) the name of the command.

    I think I have the process right until step 4. How does one enter a command? If I click the "Show" button no screen is brought up.

  3. EdgarRothermich

    EdgarRothermich Senior member

    You don't enter the Key Command in the Controller Assignments Window. You do it in the Key Commands Window, where you assign an "Controller Assignment" instead of a "Key Combination" to a Key Command.

    In your step four, the Command field is "read only". Click on the "Show" button below. It opens the Key Commands Window, where you select the Key Command you are assigning to the external controller. The Assignments area on the right (of the Key Commands Window) displays the external controller and the Assignment column list the number, how many external controller assignments are made for a specific Key Command.

    In my book "Logic Pro X - The Details" I explain all those details about the Key Commands and the Controller Assignments (a complete chapter), based on the current Logic version 10.1
  4. nautonnier

    nautonnier New Member

    Hi Edgar and thanks for your reply.

    That doesn't work. As noted, when I click the Show button on a new controller assignment, the Key Commands window is not brought up. The Key Commands window does pop up if I click Show on a preexisting assignment (say, in one of the assignments in the LogicPad OSC template). However, I cannot select a new Key Command that way. So either way, that doesn't seem to be working for me.

    I could learn a Key Command by moving a MIDI control but since I am on an OSC template there's no way to "learn" it like that. Even if I were to learn it via MIDI (instead of OSC) when I do that it creates a "Learned" controller assignment rather than using an existing one that I wanted to map. So if I were to accept this process, how would I move it to the zone/mode of my choosing?

    I ask the above because I'm thinking of just using a dummy MIDI button in my modified LogicPad template, "learn" it and then "unlearn" it later by adding the OSC value and deleting the MIDI value.

    Forgot to mention, I am on Logic 10.1.1
  5. EdgarRothermich

    EdgarRothermich Senior member

    Did you try to trash the .cs preferences file. I might be corrupted.
  6. nautonnier

    nautonnier New Member

    This is a pretty new install but it didn't hurt to try. But no this did not work either. On a brand new .cs with zero other assignments present, when I click the "Show" button on a new controller assignment that I create, no window opens up.
  7. nautonnier

    nautonnier New Member

    Bug? Any other ideas? From anyone?

Share This Page