1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Auto split notes in polyphonic staff styles

Discussion in 'Logic Pro X' started by Uwe Rodi, May 12, 2015.

  1. Uwe Rodi

    Uwe Rodi Member

    When I checkmark this option in Score preferences all the Bass Notes are sustained. (Screenshot 1)
    When I disable the option and play the same it looks this way:
    (Screenshot 2)
    Is there a way to avoid this behavior or is it just a bug?
     

    Attached Files:

  2.  
  3. Doug Zangar

    Doug Zangar Senior member

    I can't tell enough by the attachments or info you provide.

    Are there other notes/parts occurring at the same time? Were the notes that long originally and other notes previously on the same channel trim them? Is No Overlap on or off?
     
  4. Uwe Rodi

    Uwe Rodi Member

    On both screenshot I played the notes legato. There are no other notes occurring at the same time.
    I'm not sure what you mean with NO Overlap. I find this only in Score Editor an it changes only the way it is shown in score.
    The problem only occurs in the lower staff. The length of the notes are all until I stop recording.
     
  5. Doug Zangar

    Doug Zangar Senior member

    No Overlap is indeed Score Editor only - my mistake.

    I tried recreating your situation. I used the 1/3 polyphonic staff style. Works fine here if I did it right. Which Polyphonic staff style did you use?

    Can you recreate this on a new project? Just trying to rule out file corruption.
     
  6. Uwe Rodi

    Uwe Rodi Member

    I tried it again:
    I made a new project without using a template.
    I created the default software instrument (Classic Electric Piano)
    I selected Staff Style Piano 1/3 in the Track window of the main window
    I checkmark Auto split notes in polyphnonic staff styles and set the split notes at C2
    I start recording
    The result:
    All notes lower C2 are sustained until I stop recording
    All notes higher C2 are as I played them
     
  7. Doug Zangar

    Doug Zangar Senior member

    OK, I followed your directions and I don't get what you get. Notes on both sides of the split point behave the same. Perhaps we're on different versions of Logic and/or the OS?
     
  8. Uwe Rodi

    Uwe Rodi Member

    I'm using a MacBookPro (late 2011), MacOS 10.10.3, Logic 10.1.1
     
  9. Doug Zangar

    Doug Zangar Senior member

    OK, same version of Logic and OS as I'm using. It's possible there is an issue with corrupt Logic prefs. Maybe rebuild those? Otherwise I'm out of ideas, sorry.

    Anyone else want to try to reproduce this?
     
  10. CSeye

    CSeye Senior member

    Following your steps, Auto split notes checked on as above is functioning as expected. See attachment.

    If something unusual is project specific, it doesn't occur when opening a new factory Empty project template.

    If the issue is still present in the Empty project, then it would point to corrupt preferences.

    Logic Menu>Preferences>Initialize All Except Key Commands
     

    Attached Files:

  11. Uwe Rodi

    Uwe Rodi Member

    Thanks a lot. Initializing the prefs was the solution!
     
  12. Doug Zangar

    Doug Zangar Senior member

    Excellent!
     
  13. Uwe Rodi

    Uwe Rodi Member

    Oooh, the problem is still here!
    But I found out, that it is only appearing, when I have a score window opened while recording. If I close the score window everything is working perfect, when I reopen it while recording all Bass clef notes are sustained until I press stop.
     
  14. CSeye

    CSeye Senior member

    Thank you for posting your solution. It may be of help to others.
     
  15. Doug Zangar

    Doug Zangar Senior member

    I can recreate this with the score window open along with the PR. Here the notes below the split point (C2) behave as if I had selected force legato, this happens during the recording process. Clearly a bug IMHO.
     
  16. CSeye

    CSeye Senior member

    I'm still not seeing the issue here:
    - Score open in the consolidated window
    - Separate Score window open with Piano Roll open in the consolidated window.

    Note lengths in the PR are as expected for various note values below C2: half to 16th.

    View>Duration Bars reveals no excessive note length.

    Wouldn't hurt to bring this to Apple's attention:
    Logic menu>Provide Logic Pro Feedback.
     

Share This Page