1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Automatic Management of Channel Strip Objects...?

Discussion in 'Logic 9' started by mk3, Jun 17, 2010.

  1. mk3

    mk3 Senior member

    Hello, all....

    A couple of questions about the Project Settings: Audio: Automatic Management of Channel Strip Objects checkbox:

    Since I've begun using folders, I recently experienced the following problem: Normally, when creating a new track (Track: New or + button on Arrange window), the new track is assigned to an unused, unique, channel strip. However, sometimes (not always), if certain channel strips are not associated with the tracks visible at the given level of the Arrange window, as when they only exist in subfolders, then those channel strips get "recycled" and assigned to the new track! This is obviously dangerous as one might modify settings for the channel strip and thereby created unwanted changes for the track which now shares the same channel strip.

    (Another associated problem occurs in these projects: dragging regions into folders is supposed to create a track in the folder with the same channel strip assignment. Instead, sometimes the region just gets added to one of the tracks already in the folder! Also very dangerous.)

    The work-around is to turn off Automatic Management of Channel Strip Objects in the Project Settings: Audio. To my surprise, though, even with this setting off, creating new tracks still leads to the creation of new environment objects. That's fine by me, but I thought that was only the behavior to expect with the setting on. This being the case, what exactly is automatically managed? The manual is rather vague on this:

    "Automatic Management of Channel Strip Objects checkbox: Makes setting up and using tracks and channel strips a transparent experience. It automatically creates and manages channel strips when new tracks are created. You should only deactivate this setting when you need to make manual changes to channel strips in the Environment window."

    Any elucidation of exactly what this setting controls would be helpful. Also, if this setting, or the use of folders, or the combination thereof, are bug-infested disasters to be recommended only to sworn enemies, please do let me in on the secret.

    Thank you in advance for any insights....

    Cheers,
    mk3
     
  2.  
  3. mk3

    mk3 Senior member

    A further anomaly occurring now:
    When using Bounce in Place, with the option to create a new track, Logic also instead "recycles" an existing audio channel strip, one which already has track(s) routed to it. This is presumably a bug?
     
  4. ButchGTR

    ButchGTR New Member

    I feel your pain. I HATE this feature.I see no purpose for it.If I want to dup a track I'll do it...it's easy...If I want to add a track I'll do it... I don't want LOGIC thinking for me.

    To boot it's so inconsistent.It should be a preference at minimum not a song setting.The Appleisms are a waste of time.I wish they'd fix the obvious bugs and get rid of the plethora of useless crap instead of new bells and whistle features (yeh nothing new on that rant front..sorry just venting!!).

    BP
     
  5. Colin Shapiro

    Colin Shapiro Senior member

    Actually, I find the automatic creation of Aux objects very useful when configuring multiple-output instruments.
     
  6. mk3

    mk3 Senior member

    I think it is a useful option, but it is not clear what it does differently when it is turned on and turned off....as even when it's off, creating new tracks still seems to create new environment channel strip objects.

    The problem is that the behaviour is now inconsistent, whether the setting is on or off. It used to work fine always here. Now, more often than not, creating new tracks, bouncing, etc do not create a new channel strip objects.

    I have to test further whether this is only a problem in projects using Track Folders, as I only recently began using said Track Folders. Otherwise, perhaps some update of Logic broke the feature, or it is some problem/corruption specific to my system and/or project.

    That's why I would be very interested to know: Do others experience the inconsistency (that is, of sometimes new environment channel strip objects being created, and sometimes not)?

    Thank you for any input on this....

    Best,
    mk3
     

Share This Page