Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Automatic record enable on software instruments and MIDI

Discussion in 'Logic 9' started by o.m., May 18, 2012.

  1. o.m.

    o.m. New Member

    When I activate a software instrument or MIDI track in the arrange window, they very often get record enabled automaticly. I thought it happened for every MIDI-ed track, but when checking now, only some (most) of the tracks do. This also happens if I activate the track while recording, ie for adjusting the volume.

    Is it possible to disable this feature?
    I often end up creating unwanted empty MIDI regions.
  3. Tangra

    Tangra Senior member

    This is cause the midi track "R" button behaves as "Midi Thru" as well (a very important feature). If you disable it you will find out that you will stop the midi thru to the correspondent instrument.
    As an alternative you can use the track mixer to adjust the volume etc.
  4. o.m.

    o.m. New Member

    Thanks, although I still don't understand why this needs to happen while I'm recording. While recording I would prefer if the record enable was locked to the desired MIDI-track, so I could still take a look at one of the other MIDI-tracks without ruining the ongoing recording.
  5. mk3

    mk3 Senior member

    Always hated this auto-Record enable "feature". Frequently I want to adjust something in a different track's parameters while recording another musician playing MIDI. However, if one selects another track, suddenly the MIDI is being routed through that track. I've requested over and over from Apple that there be an option to at least disable this "feature" but thus far to no avail.

Share This Page