1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Automating midi CC from Mackie Control?

Discussion in 'Logic 9' started by Naut.Sirius, Jul 15, 2012.

  1. Naut.Sirius

    Naut.Sirius New Member

    Hi All,

    I feel like this should be something obvious so I apologize if I'm being obtuse.

    I can't seem to figure out how to automate and control midi control messages in Logic from my Mackie Universal Control. For instance, I have a midi track in Logic assigned to midi channel one on my Nord Modular and in Logic Automation view I'm sending midi CC #17 to control the oscillator pitch of the patch on my Nord, I can see and edit with no problems via my mouse in Logic but I can't seem to figure out how to get the Mackie Control to let me automate via one of it's faders etc even though I have to problem automating midi volume and pan to the Nord from the Mackie.

    Any advice would be greatly appreciated :)

    Logic Pro 9.1.7, Mackie Control Universal HUI and Mackie Control C4. Midi to from the mackies and Nord into Logic via a Emagic amt8.
  3. Atlas

    Atlas Senior member

    Logic detects and assign the parameters of the Mackie controls automatically, providing that your controller is properly setup/connected. In other words, Mackie controller is plug & play with Logic.
    Normally when you move a knob or faders on your Mackie, you should at least see some reaction (MIDI messages)in the MIDI IN display in the Logic transport bar (at the bottom of the screen).
    If you don't see any message, you have to troubleshoot what is wrong with the connection between Logic and the Mackie.

    However, I strongly suggest you read the following:
  4. Naut.Sirius

    Naut.Sirius New Member

    Hi Atlas,

    Thank you kindly for your response :)

    However in my case the MCU is correctly set up as everything else works as it should. IE volume, pan, transport, plugin parameters etc. It (seems) that the problem just is that when in Logic I go to a midi track that's mapped to my Nord or K-200 or Pacarana etc and enable Automation to be viewed and edited and select a CC number from the list above volume and pan the correct midi CC will display in Logic but the fader on the MCU for that track won't grab it, it remains to volume or pan etc and I can't seem to find any command keys to map the fader to the new midi control message either on the MCU or in Logic.

    I found this link which has a work around, it's effective but a bit of a pain as I have to create a lot of extra tracks in the arrange, even though I can hide them it's still clunky.

  5. Atlas

    Atlas Senior member

  6. Tangra

    Tangra Senior member

    I'm away of my equipment right now, so I will try to assist offline...
    1. Create a Standard Midi instrument object in the Environment and label it as "Nord IN". Set the instrument port to "Off"
    2. Create a Transformer object and one more Standard Midi instrument. Label the second instrument as "Nord Out" and set its port to the Nord midi port.
    3. Cable serially the three objects: Nord IN -> Transformer->Nord Out.
    4. Open the transformer and make next settings:
    Condition Status = Control
    Data Byte 1 (Pitch) = 7
    Operation Pitch =17

    Create a track in the Arrange for the "Nord IN " midi instrument and tweak your Makie to control the Volume (the level fader) of the "Nord IN" instrument.
    The idea is: when you control the level fader if the "Nord IN" instrument the object will send CC#7 to the transformer which will transform CC#7 into CC#17 and after that it will be sent to the Nord Out instrument etc.
  7. Naut.Sirius

    Naut.Sirius New Member

    This works beautifully Tangra, thank you very much! :)

  8. Tangra

    Tangra Senior member

    Be welcome :thmbup:

Share This Page