1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Automation in hyperdraw is greyed out

Discussion in 'Logic Pro X' started by Wuiyeonkim, Nov 19, 2015.

  1. Wuiyeonkim

    Wuiyeonkim New Member

    Hi everyone~ I am using logic pro x in 2013 macbook pro. While working in hyperdraw to edit automation data like expression or sustain pedal, I found a automation line that is greyed out and totally desabled. Anyone knows how to enable greyed out automation lines and dots in hyperdraw?
     
  2.  
  3. EdgarRothermich

    EdgarRothermich Senior member

    First of all, if you are using LPX, then Hyper Draw is now MIDI Draw.
    MIDI Draw is basically MIDI Events (and Fader Events) stored in a Region, made visible as Automation Curves either in the MIDI Draw Area of the MIDI Editors or directly on the Regions in the Tracks Window.

    Regarding the "visualization", the new Region Automation is basically the same, it shows the Events directly on the Region in the Tracks Window. One advantage of the Region Automation is that the various Control Change data are now part o the "Automation Parameter" and shown on the Automation Parameter Menu button. That Button has a hidden feature (move your mouse over it), a Power on/on button. This lets you disable individual MIDI Event types, i.e. Modulation, Expression, etc. If an Automation Parameter is disabled, then it turns gray.

    Here is a tip. In the Event List, all those MIDI Events that were turned off in Region Automation have a dot in the first "L" column".
     
  4. Wuiyeonkim

    Wuiyeonkim New Member

    Thank you for your answer! I don't know whether I correctly understand what you explained or not. For the button in automation parameter button, I enabled it. But, the automation data in mididraw area of piano roll window is still gray. In the event list, yes I see a lot of "L"s. I don't know how to handle this.. I guess I have to re-record those tracks. Jesus... I don't even have score for it now...:(
     

    Attached Files:

  5. EdgarRothermich

    EdgarRothermich Senior member

    I looked at your screenshot and it seems you are missing one little information.

    You can enable/disable Automation for an entire Track by toggling the Power Button on the Track Automation Button or Region Automation Button, the one next to all the Solo and Mute Button. Move over and its Power Button appears.

    However, there is another level of on/off switch and that is: Each Automation Parameter (including any MIDI Draw data = Control Change) has their own individual on/off Power Button. Move your mouse over the Automation Parameter Button (next to the Automation Mode Button (Read, Latch, ..) and there is the Power Button (that button only appears if that Automation Parameter has at least one Control Point).

    You show on your screenshot that the Volume Parameter is enabled, but you have to select the other parameter (Expression) from that menu button and then you should see that the Expression is turned off. This is what is showing in the Piano Roll's MIDI Draw Area (gray) and he Event List (dot in the L column).
     
  6. Colin Shapiro

    Colin Shapiro Senior member

    To add some clarity here:
    A lot of note events in your screenshot have a dot next to them. This simply means that the notes are muted and they won't play.
    At bar 3 1 1 1 you have events for Modulation and Expression. These events are also muted, therefore they have no effect on your track and the automation line is greyed out.

    If you select any of the muted events, then use the key command to mute/unmute, the dots will be removed and the notes will play, or the Control or Expression events will take effect.
     
  7. Colin Shapiro

    Colin Shapiro Senior member

    You can also go to the Functions menu above the Event list: Mute Notes On/Off
     
  8. EdgarRothermich

    EdgarRothermich Senior member

    Colin, are you sure about the muting Control Change Events with the Mute Notes Key Commands?

    The Key Command is called "Mute Notes/Regions/Folders On/Off" and the Functions Menu item is called "Mute Notes On/Off". So this command is restricted to Note Events and does not apply to other MIDI Events like Control Change (Modulation, Expression, etc.) Those commands can only be muted with the Power Button on the Region Automation Button.

    So based on the screenshot, my guess is still that the Region Automation is turned for those Automation Parameters (MIDI Draw Parameters) that have a dot in the Event List.
    .
     
  9. Colin Shapiro

    Colin Shapiro Senior member

    Hi Edgar,
    Sorry...you're quite correct. The Mute command only works for notes as you wrote above. Blame my error on late-night posting. :(
     
  10. Wuiyeonkim

    Wuiyeonkim New Member

    Thank you for your answers guys. Yes, I muted a lot of notes. Dots in "L" column means not muted automation but muted notes. Anyway, that's not my problem. Automation lines in midi draw area in piano roll window is grayed out and doesn't work. It's not due to those muted notes. Other tracks are totally fine. EdgarRothermich, I tried all of your suggestions and nothing works. I guess this is sort of bugs of logic pro x BECAUSE, suddenly!, all of sudden! except one track that still grayed out, in other tracks, automation lines began working! I did nothing. I was just keep repeating to draw and erase..:brkwl: The most striking thing is, expression lines came back, but modulation is still gray!!!
     
  11. EdgarRothermich

    EdgarRothermich Senior member

    So far, I haven't heard of such a bug.
    Did you switch the visible Automation Parameter in the Tracks Window for that Track (set to Region Automation) to display the Expression data and see if it is disabled? That Power Button correlates to the dot in the Event List.
    .
     
  12. Wuiyeonkim

    Wuiyeonkim New Member

    Now I've found the reason. First, in the piano roll window, I mute a note or notes at the very beginning of a region. Then, I draw a expression or modulation line. Now it is gray!!! Again, after muting a note the first opening one of the region, then I only can draw dead automation lines!!! When I turn off the mute of the very first note, and delete and redraw the automation lines, then it works.
     
  13. EdgarRothermich

    EdgarRothermich Senior member

    Bingo, you nailed it.
    That looks definitely like a bug. It disables the Region Automation for that Parameter you draw into the MIDI Draw Area, even Smart Controls, and Volume and Pan Automation when the first Note Event is muted. That also affects existing data for that parameter in that Region.

    As a quick fix, select that Parameter in the Track Header and turn it back on with the Power Button on the Automation Parameter Button.
    .
     
  14. Wuiyeonkim

    Wuiyeonkim New Member

    Final statement! The thing I explained above only applies to some of my tracks... s.t.r.a.n.g.e...
     
  15. Wuiyeonkim

    Wuiyeonkim New Member

    I tried it in a new project and confirmed It. Yes, it's definitely a bug.:mad:
     
  16. T_Thrust

    T_Thrust New Member

    Also having this issue. Not sure when it happened, it just happened. Hunch is that it happened when I hit "split" using scissor tool on a region (instead of "keep" or "shorten"), because I never manually muted the first note of a region.

    anyway. just another of seemingly many horrible bugs ( https://www.logicprohelp.com/forum/viewtopic.php?t=114380 ) hindering our workflow. :'(
     

Share This Page