1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Beat mapping versus Flex and quantization

Discussion in 'Logic Pro X' started by madelefant, Dec 3, 2013.

  1. madelefant

    madelefant Senior member

    I have a question about my understanding of beat mapping versus flex and how they react to quantization.

    By my understanding, if I map certain points on the time bar to certain transients of an audio piece, then when I quantize other material, say already recorded midi, it should quantize to those timing variations marked by the beat maps?

    Contrasting, if I analyze an audio piece for flex, and then quantize it, it quantizes the audio, back to the existing tempo or even beat mapped tempo.


    Mike
     
  2.  
  3. Atlas

    Atlas Senior member

    Beat mapping is used to adjust the tempo playback of the project according to the tempo variations of the audio (or MIDI) toward which the beat mapping is derived from.
    The quantization is the alignment of the notes or events (MIDI or Flex-ed audio transients) to the project grid, according to the quantization parameters set in the various editors.
     
  4. madelefant

    madelefant Senior member

    I am just now horsing around with this again. The beat mapping is a nightmare. Once you make a beat mapped mark it seems that point then becomes part of the grid so you would think quantizing would adhere to the beat mapping as if it where the grid. I was working with a song recorded entirely in logic and tried beat mapping to some timing variations in a rhythm guitar. It wasn't working to well. I then protected the midi regions (which kept getting messed up) which seemed to be working but after several beat map points it all of a sudden went all out of wack again.
     
  5. madelefant

    madelefant Senior member

    Geese. Here I am again. If I turn on flex, even with no quantize settings, it seems to quantize or change the position of audio by large amounts (like half a bar). Cant figure out why. If it is one file why would it do this. I do have beat mapping to a rhythm track, but again, the beat mapping doesn't affect the track I am speaking about with no flex turned on.
     
  6. Atlas

    Atlas Senior member

    Hierarchically, tempo prevail over quantization.
    Tempo is the number of beats per minute.
    Quantization determine where those beats will fall during that minute (within the current tempo).
    Therefore tempo and quantization are two distinct things that affect the position of recorded notes.

    As mentioned in my previous post, beatmapping is the action of creating tempo changes after detecting same from a recorded audio material. The impact of the (same type of) quantization on the notes will consequently vary between tempo changes (during your project playback).
    Flex time is a way to apply quantization on audio material using the transients of that audio material (or MIDI). Tempo changes will therefore also affect (on top of quantization) the playback of the Flextimed audio material, in the same manner as explained above. Taking into account both (tempo changes and quantization settings) is mandatory to understand what to expect when dealing with them in Logic.

    Additionnally, audio material created/edited/saved within Logic will contain and carry on (among other metadata) tempo mapping (beatmapping) and flex information. Audio files from other sources could also contain such information. Consequently, loading/importing such audio material in Logic could cause such seemingly erratic effect on your project.
     
    Last edited: Feb 27, 2016
  7. madelefant

    madelefant Senior member

    All the audio files were recorded in Logic. What I think could be the problem, and I don't understand how this is dealt with in logic, is that if you record audio files into Logic, and it is recording tempo into the files, and you then do things that change the overall tempo, like beat mapping, the files may have some type of conflict with edited tempos. Seems to me it might be prudent to be able to strip any file of this tempo information ingrained in a file or replace it with other tempo information.

    Mike
     
  8. Atlas

    Atlas Senior member

  9. volovicg

    volovicg Senior member

    I was having a similar issue with flex and tempo (Till Eric set me straight in understanding Flex tempo markings).. Try this and see what happens.
    Highlight the region and Edit->Track->remove tempo
    Then turn flex on ( your region should still shrink by 1/2 bar as you describe above)
    right click on the region and select reset all flex markers. you region should "now" return to normal ( with flex on).
    Now do you you process and see if that corrects the issue.
     
    Last edited: Mar 1, 2016
  10. madelefant

    madelefant Senior member

    Thanks Volvicg. I found that menu option to strip out the tempo stuff.
     

Share This Page