1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 BlackMagic PCI video card

Discussion in 'Logic 9' started by zerobeat, Feb 24, 2010.

  1. zerobeat

    zerobeat Senior member

    Does anybody else use this video card to output video from Logic onto a TV?

    It shows up as a possible video destination in Logic's video preference, but the video doesn't play out the PCI card. In ProTools on the same computer, the video plays out the BlackMagic card perfectly.
     
  2.  
  3. Eli

    Eli Senior member

    Are you by any chance running Logic in 64 bit mode? I think this is one of the features that is currently not supported.
     
  4. zerobeat

    zerobeat Senior member

    None of the rigs we use have 64bit engaged.. we know about all the limitations. In this case, it's firewire video that doesn't work in 64bit mode according to Apple but we don't take any chances.

    Although occasionally we'll go into 64bit mode to see if something actually improves, just for troubleshooting purposes.
     
  5. Gio

    Gio Member

    works great here with me, blackmagic Intensity Pro PCIe, mac pro 2x2.66ghz, 4GB ram
    Final Cut, Logic and PT address it with no problems.
    not infront of my rig right now, but you might need to check which codec your mov has. some dont jive with blackmagic.
    check the system prefs on the blackmagic tab.
    good luck
    ciao
    gio
     
  6. felix fog

    felix fog New Member

    hello Gio

    sorry for my english.....

    i have installed yesterday the black magic intensity pro in a macpro 2,66x2 dualcore intel xeon 16giga osx 10.6.2, and all is ok with pro tools, but not in logic studio pro 9.1.1....

    i ve you an idea of what hapens?

    thanks

    fog
     
  7. Gio

    Gio Member

    Hey fog,
    go into Logic's prefs> video.
    in there you'll see a choice of Apple display and a couple of blackmagic choices, try them both, that should get the video streaming to the intensity card.
    I have had problems before sending a quicktime encoded with H.264, try converting it to a prores or a dv stream, that works on this end.
    Ciao
    Gio
     
  8. Soundgram

    Soundgram New Member

    Logic Pro 9 and blackmagic HDMI card for TV

    Hi all,
    thanks to a post here I sorted my :brkwl:problem:
    I am running a 8core mac with blackmagic intensity card on a 50" LCD TV

    first: Startup Logic 9.1.3 (update needed) in 32 bit mode (Use cmnd i)
    install latest drivers from the blackmagic site for OSX
    second: with the video prefs set Blackmagic as video output and select external video out.
    third: Make sure your video is coded with the apple Pro Res 422 HQ!
    You can use fcp, quicktime or (best) compressor to export to Pro ress
    last: make sure your HDMI cable is conected and the HD format (HD1080 i50) is the same on the input of your TV

    That should do it! It works with me:thmbup:
    Regards, Johan (soundgram.com)
     
  9. zerobeat

    zerobeat Senior member

    If the card works perfectly in ProTools, but not Logic (same computer - same everything else), is there still some other hoops one has to jump through to get this card to work in Logic?

    Does Logic support less video codecs than ProTools does? I thought that was a hardware issue??? If it's Logic's fault, then it needs to get updated to work with all codecs that ProTools works with or else at least a few composers I know will ditch Logic once and for all. But these same QuickTime movies work perfectly fine in the local video window inside Logic.. just not out the BlackMagic card.

    By the way, we attach a Canopus ADVC110 Firewire box and Logic plays back movies perfectly fine via this box (DV codec only obviously, since it's a Firewire box).
     
  10. sonnykeyes

    sonnykeyes Senior member

    This may be painfully obvious to you, but it wasn't to me, so forgive me...In L9 there was a new box in the Project Video Settings at the top that says "External Video Output" and the picture didn't come out my BlackMagic card until I checked that. Took me a while to figure out.
     
  11. zerobeat

    zerobeat Senior member

    Yep, that's checked. It's the only way to get the Canopus box to work also.

    But it is indeed weird that even though you might choose the correct video output in the flipmenu below, you still ALSO have to check this box for it work. You'd think that it should be implicit that if you choose an external video output, that you want an external video output!

    It would be like choosing a BUS destination for an audio track (instead of OUTPUT), but also have to check a box called "route to BUS".
     
  12. sonnykeyes

    sonnykeyes Senior member

    It may have been conceived as a convenience for people who experience a frame or two of delay to their external video (a new wrinkle since the advent of flat screens) so you can quickly flip back to the video on the computer monitor to check sync. I have certainly found it to be helpful for that purpose.
     

Share This Page