1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bought a new Mouse & past Logic projects crash on startup...

Discussion in 'Mac OS' started by charlie, Mar 3, 2012.

  1. charlie

    charlie Senior member

    Well, I have to admit that I am a bit stumped as to why connecting a new wireless mouse prohibits me from opening active on-going projects in the latest Logic 9...:eeek:
    But I can open brand NEW Logic sessions via my templates...
    Any one out there with driver compatibility knowledge, please step forward... ;)

    I needed a new mouse, I looked around & purchased a Logitech Performance Mouse MX after reading generally favorable reviews etc.
    This Logitech mouse is wireless and connects to the computer via a small usb "dongle" using something called 'Unifying' technology. (This isn't Bluetooth, it's some proprietary wireless communication that Logitech developed.)

    Upon opening Logic, the initial splashscreen appears and all the drivers seem to load as they always do.
    The window pops up asking if I'd like to open my most recent project etc...
    I click ok.
    Everything loads until it gets to the AU validation of my Soundtoys Phasemistress plug.
    This is when I see an error I have never seen before in Logic:
    http://www.logic-users-group.com/forums/attachment.php?attachmentid=596&stc=1&d=1330788987

    I click ok and am presented with Logic's Templates menu.
    When I choose a new template to load, the crashed Logic progress bar stays up and Logic does not function.
    Most features and functions are greyed out.

    I cannot Quit Logic as shown here;

    http://www.logic-users-group.com/forums/attachment.php?attachmentid=598&stc=1&d=1330789209

    I must force quit every time.

    Logic opened fine (same project,) earlier that day. The only thing that had changed since was the installation of the Logitech Mouse software and this physical dongle.:confused:

    To troubleshoot, I disconnected the mouse entirely and used my wife's Apple trackpad to navigate and was able to open Logic and even instantiate a Phasemistress plug-in with no issues.

    Any input is appreciated. :hippy:
     

    Attached Files:

  2.  
  3. charlie

    charlie Senior member

    More on this...:
    I ran Disk Utility & verified/repaired my Mac HD but it had no difference.:confused:

    As I open different "on-going" projects in Logic, (ie; "NOT new,") Logic faithfully crashes upon the validation check of different plug-ins.
    The project I showed in my pics showed Logic crashing on a Soundtoys Plug-in (Phasemistress,) a different project always seems to crash on the Logic Channel EQ and yet another crashed on Logic's own Klopfgeist showing that this most likely is not a 3rd party issue...:confused:
    For whatever it's worth, I also have an iLok in a powered USB hub that is working fine and the bluetooth wireless Apple keyboard and a trackpad running on my system as well...

    I have opened Avid Media Composer and Adobe Photoshop with no issue since installing this Logitech mouse, and am quite stumped by this.
    What is Logic not liking about this minor change in my system?:brkwl:
     

Share This Page