1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 can't easily delete unused tracks

Discussion in 'Logic 9' started by peterlemer, Sep 13, 2010.

  1. peterlemer

    peterlemer Senior member

    My main instrument, for tracks and for experimenting, is Piano (Ivory).
    When I do multiple takes in cycle mode and pick the best version, I then delete all the unwanted regions (takes).

    This leaves me with a welter of unused tracks, but because there's already automation on the original piano track, every empty track also has automation, so the 'delete unused tracks' doesn't see them as unused.

    Deleting the tracks singly seems to take a long time and impedes my workflow.

    Any suggestions to remove this time penalty?

    pete
     
  2.  
  3. georgelegeriii

    georgelegeriii Senior member

    Just select the unwanted track and press delete... I can clean a song with about 30 or 40 tracks in about a minute.
     
  4. peterlemer

    peterlemer Senior member

    I have to wait about 10-20 secs for each deletion to complete. SBBOD regularly appears.

    pete
     
  5. Doug Zangar

    Doug Zangar Senior member

    You might try creating a new track with duplicate setting and copying or moving region. Automation should go with it, depending on preference setting. Then do your process.
     
  6. georgelegeriii

    georgelegeriii Senior member

    The problem with the "make duplicate" with a track using Ivory is that you will run out of ram pretty fast.

    That said, are you sure you are using the same instrument for all the tracks? It shouldn't reload each time you delete a track.

    Mind you, I have heard of this on the occasion IF you are close to using all your ram and your Logic song is using allot of ram as well. It's just not a "happens every time" thing


    I just checked using a song with about 25 tracks... it takes about 10 seconds to delete the region and then delete the track.
     
  7. peterlemer

    peterlemer Senior member

    george:

    > are you sure you are using the same instrument for all the tracks?

    If that's addressed to me, then no - the new tracks are being created when I 'create tracks and mute in Cycle record' - so when I delete the regions ( fast) I am left with a lot of empty identical tracks - all of them with automation!

    > I have heard of this on the occasion IF you are close to using all your ram > and your Logic song is using allot of ram as well.

    How do I monitor this? I often have to restart logic after working a for while, as I start to get slow processor warnings. So something tends to clag up.
    I have 7G RAM installed.

    > I just checked using a song with about 25 tracks... it takes about 10
    > seconds to delete the region and then delete the track.

    do you mean 'tracks'? or 10 seconds for each one individually?

    pete
     
  8. peterlemer

    peterlemer Senior member

    Doug:
    If I create a duplicate track and move region, all the empty tracks will still contain automation and be slow to delete.

    pete
     
  9. georgelegeriii

    georgelegeriii Senior member

    10 seconds per individual track in Logic... max

    This doesn't seem to make any sense to me.

    Would you please send me a song that has this issue, I can take a look and see what is going on.

    george @ georgetechguru . com
     
  10. Doug Zangar

    Doug Zangar Senior member

    2 ideas:

    1) Try MIDI take folders instead of create new tracks

    2) Try this workaround.......

    Create new empty SI track (Rhodes may load by default). Copy performance region of choice to this track (Automation will come with it if preferences are set correctly). Make sure any one of your performance tracks are selected, use delete automation command. Delete all your regions except the one you want, which is on the new SI track. Drag that region back to performance track of choice, with automation. Do the delete unused track thing.

    Caveat: this will probably create new nodes at the border of the region - watch for that so it doesn't affect other automation.

    This all works on 9.1.1, not sure what version you're using.

    7 gigs of RAM really doesn't count if you're not in 64 bit mode.

    And of course, if you played the performance perfect the first time you wouldn't have this problem...;)
     
  11. Eli

    Eli Senior member

    Hi Pete,

    I've been following this thread and read your original post again - which gives me a clue as to what may be going on.

    You say you do multiple takes in cycle mode and then delete the unused takes. So, I am assuming you are recording to a take folder. How exactly are you deleting the unused takes? If it leaves you with a "welter of unused tracks", it sounds to me like you are unpacking the take folder to new tracks at some point before deleting them. I think this may be what is causing your problems. You shouldn't be unpacking them at all - that is likely the step that is creating the additional Ivory tracks; which not surprisingly take a while to delete (because each instance is so big).

    Why not just stay in the take folder, and switch to edit mode. Then you can delete the takes you don't want directly from the take folder without having to create new tracks.

    I may be way off here - but do you think this might be what is going on?
     
  12. sonnykeyes

    sonnykeyes Senior member

    Peter, I'm confused - does Ivory also write automation while you're performing? I just tried doing what you're describing using Play, which is my most processor-heavy SI, and I still have to write automation after the performance passes are done, then unused tracks disappear instantly when I hit the KC combination, although as you say, Delete Unused doesn't work because of the automation. What's your system again? I'm sure you've posted it before, but I've forgotten.
     
  13. peterlemer

    peterlemer Senior member

    doug, if I understand you correctly, this cannot work because even if I delete automation on a performance track, it won;t do so on the other tracks. I would have /more/ work deleting automation individually, then deleting the tracks themselves ( albeit they will then go faster)

    I'm using v 9.1.1

    I'm not in 64 bit because I have a first series Intel 2.66

    I DO play perfectly the first time, but then I play even better!!! ;-)

    ...and there are clients, and there are sections where I improvise until I get the perfect approach...and so on ad nauseam

    pete
     
  14. peterlemer

    peterlemer Senior member

    I don't use take folders. I don't even know what they are!
    They must've come in around 1995 when I stopped reading the manual <g>

    I'm simply recording with the option set to create new track in cycle mode and mute previous.

    Maybe this is the root of my solution?

    now... where's TFM?

    <takes note to go up to attic with garlic, crucifix and dustbuster>
     
  15. peterlemer

    peterlemer Senior member

    sonny: L 9.1.1, mac Intel 2.66 32 bit

    Yes, this involves doing retakes /after/ automation has been written.

    eg. on this salsa project I've designed a basic montuna which work in particular sections, and in synch with a variety of SIs. Then the singer lays a guide vocal, the horns and singers and percussion come in and do their thing, all of which requires a touch of automation here and there, as well as manual, both for headphone balance and for doing trial bounces.

    As the project ripens, time comes to sculpt the piano - all that repetition is fine for some bits, not for others. So I get down to slight/extreme variations to suit. With all that rich stuff already on there, perc, voices, horns, even solos, finding some dream pinao is great fun :) And I often use cycle record for that... and there will be some automation on that track.

    ditto with other projects. - I can get final versions of keyboard tracks much more joyfully once most of the rest is down - and by then there will have been automation on pre-existing 'guide' piano tracks.

    pete
     
  16. sonnykeyes

    sonnykeyes Senior member

    If you look at all the tracks created in Loop-Record with the Automation showing, you'll see that Automation exists only once and all tracks show the same nodes. Deleting the Automation on one of those tracks deletes it on all of them.

    If your system doesn't behave that way, that would be your first clue why it takes so long to delete the unwanted tracks!
     
  17. Doug Zangar

    Doug Zangar Senior member

    Well, I'm confused as well.......

    If you are recording MIDI, using the cycle region and having Logic create your new tracks (which will be clone tracks of the original SI) my suggestion will work - I tested it here.

    So if you're going and doing retakes, are these tracks clones of the original or are you creating a new (unique) channel strip and SI instance for each take?

    The clone tracks share the same automation - look at them and change a node somewhere - they will all change if they're clone tracks. If they don't change together then they are unique. If they are unique then it's going to be a different method to delete quickly.

    And BTW - you're good! Perfect track the first time and variants after that - damn! ;)
     
  18. peterlemer

    peterlemer Senior member

    Doug. thanks. L9 9.1.1, 32-bit Intel Mac.

    > Create new empty SI track (Rhodes may load by default).

    I created a new track with a new instance of Ivory. for example

    > Copy performance region of choice to this track (Automation
    > will come with it if preferences are set correctly).

    done, and yes, the automation copied ( and created new nodes at the borders)

    > Make sure any one of your performance tracks are selected,
    > use delete automation command.

    yes, that deletes automation on all shared tracks - including automation on the same track relevant to other parts of the song!

    > Delete all your regions except the one you want, which is on the > new SI track.

    done

    > Drag that region back to performance track of choice, with
    > automation.

    now sitting in a chain of regions where all previous ( and precious, perhaps) automation has been wiped - when all I need to is to wipe the local automation linked to the current region. Is there a way to this?

    pete
     
  19. Doug Zangar

    Doug Zangar Senior member

    Ah, the second set of eyes.....

    You're absolutely correct. I didn't do my test with other regions on the same track, just assumed if there were some then you'd need to do XYZ.

    So, in order to avoid complete embarrassment and to give an illusion that I sometimes kind of know what I'm talking about, here's an augmentation of that idea.

    Copy the track automation first. You can paste it to an empty track if you feel safer that way (highly recommended) or just leave it in RAM for the duration of the process. Option click on the first node of the automation lane will highlight all nodes of the track. Copy this. Paste to track of choice. If you don't copy anything else it will still be on the clipboard when you want to paste back to performance track.

    With that copied, delete the original track automation so it doesn't impede progress. After cleanup, paste automation back to performance track. With this method you would never need to copy automation while moving regions from track to track, and in fact, having deleted the automation would keep the dialogue box from popping up.

    Not sure if any of this saves time, but my guess is it does.
     
  20. pjl

    pjl Member

    I use take folders and I find that getting rid of unused takes is a simple matter of selecting and deleting the regions. There are no extra tracks to delete as they vanish automatically when the regions are deleted.

    However, I can't recall if I have done this on a track with automation so I don't know if that would complicate matters.

    Peter,
    In the Recording Settings... change the selected MIDI option from:

    "Create tracks and mute in Cycle record"

    to:

    "Create take folders"

    After you have recorded your takes, click the disclosure rectangle at the top left of the new region and you should see all your takes, effectively as separate lanes on the same track.

    Clicking a take to highlight it will make it the one playing back and automatically mute all of the others.
     
  21. peterlemer

    peterlemer Senior member

    ah eli - cor blimey! I've been using take folders for audio for some time now, without knowing that that's what they're called!

    It hadn't clicked that I could do the same with MIDI, minus the comps.
    that'll definitely solve my problem.

    I shall withdraw to bed now and suck my thumb

    pete
     

Share This Page