1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Cant install Logic 9 in G5 dual 1.8 ppc?

Discussion in 'Logic 9' started by G two, May 9, 2011.

  1. G two

    G two New Member

    I cant seem to install Logic 9 onto my G5 dual 1.8 ppc? Mac released 2004
    OS X 5.8

    When i try to install logic 9 a message come up saying, "Your computer does not have the hardware required to run this software". " This software requires a mac with an intel processor"

    Ive heard logic 9 does work on ppc macs, but so far not on my one.
    Is there a way to get around this without buying a intel mac?
  3. Markdvc

    Markdvc Administrator Staff Member

    HI there, welcome to the LUG.

    While the first versions of Logic 9: 9.0.0, 9.0.1 and 9.0.2, according to user reports, could be installed on PPC Macs, Apple never officially supported the PPC platform for Logic 9. Since 9.1 Logic is Intel only. Presumably you have a more recent version of Logic, 9.1.0 or later. This can only be installed on an intel Mac.

    kind regards

  4. G two

    G two New Member

    Oh no looks like im gona have to get an intel mac.

    Cheers for your reply.

Share This Page