Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Can't solo track with hardware comp

Discussion in 'Logic 9' started by Calitone, Apr 8, 2010.

  1. Calitone

    Calitone New Member

    I recently purchased a nice hardware compressor and wanted to hear it in one of my mixes. So I inserted the compressor using the I/O plugin.

    What's weird to me is, when I solo the track, I can't hear it. When it's not soloed I hear it fine.

    Is there something I'm missing here?

    Shouldn't I be able to hear the track that has a compressor inserted via the I/O plugin when I solo it? :brkwl:
  3. Maurits

    Maurits Member

    The I/O plugin uses an output object to stream the audio to your external hardware. This output object will also be muted when you switch on solo.

    The solution is to set the output to solo-safe. For this you might have to add it to your environment if it's not already there, or look it up in the track mixer. Then you can solo-safe it so that it won't be muted in a solo situation - sorry I forgot how that worked, I think it was alt-click on the solo button or something similar. :)

  4. Calitone

    Calitone New Member

    Tried solo safe. That didn't work. I guess it is something on the environment. Unfortunately, I don't know how to set it up. I wish it were as easy as it is in Pro Tools. :(
  5. Maurits

    Maurits Member

    The environment only gets complicated once you start routing things yourself, ie you _want_ it to be complicated. :)

    I just realized you won't see the output in the mixer window either unless you made a track in your arrangement that is assigned to the output.

    Did you solo-safe the _output_ used by the I/O plugin and it still didn't work? Or didn't you know where to find the output object in the first place?

    In the latter case, go to the environment, copy one of the other audio object faders (alt+drag) and change the channel assignment of the new copy to "Output xx" (xx corresponding with the output you used in the I/O plugin). If you solo your track, you might see this output muting too. If you solo-safe it, it should work.

  6. Calitone

    Calitone New Member

    I solo safed on the mixer. So I'm sure I did it wrong. :confused:
  7. Maurits

    Maurits Member

    Yes, but WHAT did you solo-safe? :)
  8. Calitone

    Calitone New Member

    I didn't solo safe anything from the environment, if that's what you mean. I just ctrl-clicked or command-clicked (forget which one) the solo button on the channel strip in the mixer window.
  9. Maurits

    Maurits Member

    I still think you're missing the most important part, if not I'm sorry for repeating myself. :)

    You need to solo-safe the channel strip corresponding to the *output* used for the I/O plugin. Not the channel with the I/O plugin itself.

  10. Calitone

    Calitone New Member

    You're explaining yourself well. I'm just not understanding. LOL!!

    So how would I do that then?? Where do I find the output that's used for the I/O plugin? Logic is really making me feel like an idiot. :brkwl: HAHA!
  11. Maurits

    Maurits Member

    In the environment or the track mixer, but for both you have to do something to make it visible.

    First, check which output you use in the i/o plugin. But I'm assuming you know which output it is or you wouldn't get your outboard hardware to work at all. :)

    Now, if you create a new track in the arrange window (which you can then leave empty) and assign it to this output (instead of a midi channel or a software instrument), the fader for the output will be in the mixer window. (The mixer contains everything that's in the arrange window, in the same order).

    If you don't want the empty track in the arrangement, the other option is to go to your environment and copy one of the channel objects (by dragging it while holding down ALT). Then select the copied object, and change it's channel to the correct output.

    In both cases you'll have a fader that corresponds to the output (and you will also see the level indicator of the fader display the signal going to your compressor, which is also convenient) :) and that you can set to solo-safe.
  12. Calitone

    Calitone New Member

    I'll give this a try tonight. Thanks for all your help!
  13. Calitone

    Calitone New Member

    HURRAH!!!!! Finally got it to work!! Thank you so much for your help. However, I think it's quite a bit to have to do to solo a track with hardware inserted on it. Doesn't make sense to me why I have to go through these steps. Much easier and more "logical" in Pro Tools. However, I'm just glad I got over this hurdle. Couldn't have done it without you. Thanks!
  14. Maurits

    Maurits Member

    In that case 'logic' means never muting outputs in a solo situation, but that's easy to accomplish: Just solo-safe ALL outputs in your default song and save that, and you'll never have to worry about this again. (Except in your already existing projects). :)
  15. mauriciohersz

    mauriciohersz New Member

    Hey Maurits, I was having this same problem and solved it thanks to your explanation! But I could only get it as far as creating a track in the mixer and assign it to the compressor outputs and solo safe it...can you please be more specific about how you set this in the environment so I don't have this "ghost" track in my arrangement? What do you mean by "copying the object" in the environment? Thanks so much for your help!

Share This Page