Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Chaining AUX Tracks Creates Latency?

Discussion in 'Logic 9' started by afavreau, Mar 24, 2010.

  1. afavreau

    afavreau Senior member


    Can someone tell me if this is normal?

    To create Submixes, it seems that I can chain an audio track to many bus tracks in a row. (Meaning, to put my 3 Kik tracks to a single bus track, then send that bus track to another submix etc...)

    But when I try the same thing with AUX tracks, it doesn't work! I start having some serious latency between tracks and my drummer suddenly has rythmic problem!

    I've found out that on my system, an Aux track can only come from an Audio track and go directly to the main Output to avoid this.

    Is this normal? Am I the only one?

    According to Logic"s manual, AUX tracks are the corrects ones for submixes and effects.


  3. jlproductions

    jlproductions Member

    You'll need to change the latency setting in your preferences/audio/compensation to ALL from Tracks and Instruments if you want to do this. This is only a hassle because it becomes global for all your songs and you have to remember to switch back and forth. (I wish this would be a song setting pref and not a global one!)
  4. bobdemaa

    bobdemaa Senior member

    I leave compensation to ALL always. I don't have a reason to ever want it off.
  5. georgelegeriii

    georgelegeriii Senior member

    Won't that end up moving the midi data to the wrong place is you are using a plugin that has a large amount of latency? That's why I am always changing it back and forth depending on if I'm tracking or mixing...

    George Leger III
  6. bobdemaa

    bobdemaa Senior member

    Moving MIDI Data? ummm. no? That doesn't happen to me or I don't know what you mean.

    If I have a software inst bussed to an aux with large latency. ie. altiverb followed by Ozone 4 and PDC is not set to all, then there is an obvious and awful amount of latency.

    Setting PDC to all corrects that, and does not move my MIDI data at all.

    It was my understanding that PDC is strictly delay in the audio domain.

    If you are referring to trying to play an instrument that has been bussed this way, then of course it will be unplayable, that is what the Low Latency Mode Toggle is for.

    Hasn't been a problem for me.
  7. bobdemaa

    bobdemaa Senior member

    I just confirmed that even with chaining the aux output to aux to aux, all with Altiverb and Ozone 4 on them everything stays locked to picture with PDC set to all.

    The Problem with inducing such huge latency is that visually the playhead looks like it is way ahead. It does require a different level of attention to the music as you can't trust your eyes at that point. Not a problem for me, but an issue nonetheless and one that could, I imagine, be addressed by apple at some point.
  8. afavreau

    afavreau Senior member

    The Latency I have and that I explain in the beginning is with PDC on. I know how PDC works.

    Basically, when it's off, there is no compensation.
    When set to audio Instruments, it's for recording
    and when to all, for mixing or playback.

    However, I'm still confused as to why a submix (Aux Track) that goes to another submix (Aux Track) would create latency as opposed to bus tracks that don't create Latency. It's unfortunate that Bus Tracks don't have any sends.
  9. bobdemaa

    bobdemaa Senior member

    From the L9 Manual
    Bus Channel Strip:

    You can only create bus channel strip objects in the Environment. In general, you will not need to do so, as all audio bussing (send/return routing via the Send slots of channel strips) is handled by aux channel strips.

    Bus channel strips are primarily included for compatibility with earlier versions of Logic Pro, and for use with certain audio hardware devices.
    From a technical standpoint, the Bus shouldn't have a channel strip. It's an incorrect usage to give the bus a channel as "buss" refers to routing and is probably why it was "removed" from normal usage in 9. Even in 9 it technically isn't correct as the Bus Strip interrupts the buss, not logical at all.

    The Aux Channel is "correct" as it includes the busses destination and creates the channel strip with level control.

    I just tested cascading 4 auxes and with no plug-ins and PDC off, there does not seem to be any delay I can detect.
  10. Peter Ostry

    Peter Ostry Administrator Staff Member

    It's not. There must be something wrong with your buses. You may check them one by one, reset their settings, switch them from stereo to mono and back, delete them and never use them again as channelstrips. If this does not help, you have to continue with a new project. Or finish this project as it is but work without bus channelstrips in future. Buses are just the roads where your data travel. They can be made visible for backwards compatibility because the old Logic versions didn't have Auxes. Aux is the way to go.

    Auxes and sends are sample accurate, there must not be any delay. Look at the screenshot below. I inserted a Test Oscillator with pink noise (!) and sent it directly to the output and in parallel through six buses. To make the situation worse I delayed the stereo channels. After six buses, when the phase of the bus signal gets inverted, there is zero output. Nothing. And when a noise signal cancels itself with the phase inverted, you can be sure that there is no delay at all.

  11. bobdemaa

    bobdemaa Senior member

    That's what I was trying to say... Just lacked the elegance that Peter has. : ) thanks.
  12. Badger

    Badger Member

    Maybe it's the plug ins you have on the aux. Try the same with logics own plugs and see if anything changes.
  13. afavreau

    afavreau Senior member

    Thanks Peter!

    Yes! There's must be a problem with my Environment mixer.

    Sometimes my Audio tracks switch from Mono to Stereo for no reason. I think it's because I imported my Autoload from...Logic 7 directly to Logic 9. I never had Logic 8. Something must of happened there.

    I guess I'll have to rebuild my environment... ouf!

    Thanks again!


Share This Page