1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Changing the sample rate

Discussion in 'Logic 9' started by Jim S, Dec 10, 2011.

  1. Jim S

    Jim S New Member

    I am importing projects from Garageband to LPro 9 and I wanted to try to step up the sample rate to 96K but the audio tracks I recorded don't work. Is there a way of doing this without losing recorded tracks?
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

    Welcome to the Forum, Jim. Did you Sample Rate Convert the audio files when you imported them into your 96 kHz Logic project? In the bin, open audio files, use the copy/convert command. It is also accessible with ctrl + c.

    I presume they are either 44.1 or 48 kHz?

    kind regards

    Mark
     
  4. Jim S

    Jim S New Member

    So there's no way of importing the whole song and converting to 96K without having to rebuild the song? The original GB project is 44.1 and is essentially complete.
     
  5. Markdvc

    Markdvc Administrator Staff Member

    Leaving aside the 96 kHz issue for a moment, are you able to open the original GB project in Logic in 44.1 kHz?

    kind regards

    Mark
     
  6. Jim S

    Jim S New Member

    Mark
    Yes, I was able to open and import the GB project at 44.1. When I bumped the Khz to 96 the digital files transferred fine but the audio files didn't. I was able to import the individual audio files to a new project but when I try to import them to the actual project the come in a double speed.
     
  7. Markdvc

    Markdvc Administrator Staff Member

    I presume by "digital files" you mean Midi, or Virtual Instruments, as opposed to audio files (which FWIW are of course also digital)? That is to be expected.

    That is also to be expected, has nothing specifically to do with Garage Band or Logic, it is rather a "digital" fact of life. If you played a 33 1/3 rpm vinyl record at 45 rpm, it will sound too fast, right? A similar thing is happening here. The solution is to select all the audio files in your project (comm + a in the bin) then proceed with the src. If you leave the names of the files as they are, save the project, then run logic at 96 kHz, the audio should play back at the correct speed.

    Before doing this, I suggest you make a complete back up of the project and all the audio files involved.


    It is also worth noting that 96 kHz audio will put a lot more strain on your Computer, it is more than doubling its processing and streaming requirements.

    kind regards

    Mark
     
  8. Jim S

    Jim S New Member

    No the audio files are guitar and other actual instruments I recorded in GB. What is annoying is that I can import the individual tracks to a new project with no problem but when I import them to the original (96K) Logic project they double speed.
     
  9. Markdvc

    Markdvc Administrator Staff Member

    What exactly does "original (96K) Logic project" refer to? Do you not wish to work at 96 kHz? If not, and if your audio files are 44.1 kHz, how about simply staying at 44,1 kHz? Sorry if I misunderstood something ...

    kind regards

    Mark
     
  10. Jim S

    Jim S New Member

    Mark, I'll start over. I created a piece in GB which is mostly done. I wanted to finish it in Logic but bump it up to 96K to improve the fidelity and allow me to do a better mix at another studio. What I was able to do was import the song with the software tracks at 96K. I have imported the guitar and other audio tracks at 96K but they translate to double speed. I suspect Flex time is part of the problem so I will continue to slog away and let you know what happened.
     
  11. Colin Shapiro

    Colin Shapiro Senior member

    Here's another way to approach this:
    Your original GB song is at 44.1k
    Open it in Logic, also at 44.1k - the files should all be fine and play perfectly.
    Now open the Audio Bin window, select the audio files and use Copy/Convert to 96k as Mark suggested above. (Enable "change file reference in bin")

    Now change the sample rate of the song - that should work.
     
  12. Jim S

    Jim S New Member

    Okay, I will try that. I also discovered that Flex time was complicating things.
     
  13. Jim S

    Jim S New Member

    ... and there it is. As you said, Colin. Import, convert and then kill the Flex. What a relief.
    Thanks
     
  14. Sascha Franck

    Sascha Franck Senior member

    If you don't plan on adding quite some further audio files (the benefits of using higher samplerates is still somewhat questional for such things anyway) and if you also don't plan on using more or less old-fashioned plugins (which may cause aliasing and whatever artefacts at lower sample rates), I would simply keep the sample rate at the value you started with.
    Most likely you wouldn't gain much fidelity - perhaps you'd even lose quality during conversion of your older files. Logic's sample rate conversion isn't all that great, so if you really wanted to go that route, try to find the excellent (but now apparently discontinued) freeware "Audiomove".

    Otherwise, I'd say stick to your original sample rate. less stress and an end result that'll probably be just as good.

    - Sascha
     
  15. Jim S

    Jim S New Member

    Right after I posted these questions my system died and I lived in terror of losing my files to a faulty Mac. No such problem and everything is back. Thank you all for the tips. I assumed, as per my analogue days, that more was always better. If I can work in 44.1 with no limitations on the final quality of the mix then my life is much easier. Thanks
     

Share This Page