1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Clicking software synths

Discussion in 'Logic 8' started by Wavetable Jackson, Mar 22, 2010.

  1. Wavetable Jackson

    Wavetable Jackson New Member

    I'm having trouble with software synths doing that random-click thing they sometimes exhibit. I have an instance of Sculpture, one of the ES2, one of Nexus, one from Kore Player and two of MOTU Symphonic Instrument going. They "sputter" at the same places, but despite tweaking the sample rate and etc., the noise persists. The total piece is only 12 tracks or so and rarely more than 8 are sounding at once. This includes 4 audio tracks from a Korg TR, but when soloed, the noise is definitely from the softsynths.

    I'm more than happy with the DAW overall, but this issue is resisting both my troubleshooting and my ungentlemanly cussing. Anybody got a pointer that might turn on that light bulb over my head? Do I have to convert the offenders to audio and DRAW the clicks out with the Pencil tool (argh)? Got a loose rule-of-thumb for how to set the rates and buffers for various setups, so as to prevent this? Thanks!
     
  2.  
  3. georgelegeriii

    georgelegeriii Senior member

    Try freezing a few of your tracks and see what happens then. You are using allot of CPU power actually. With VI's, the computer actually makes the sounds, and some, like sculpture and Kore, can really chew your power up with only a few voices.

    George Leger III
     
  4. Wavetable Jackson

    Wavetable Jackson New Member

    I already have the Sculpture track frozen, but your point is a good one. I'll try freezing a few more, as the piece is nearly done. I'm still new to Logic, so while some things translated from my previous DAW, others are calling for more study.
    I'd still like to hear a few ideas on buffering and sample rate selection. I know there's no ideal "sweet spot" for every situation, but anything else I could do to help the CPU along would be a no-brainer. Thanks for the tip.
     
  5. michaelo

    michaelo LUG Emeritus

    What size I/O buffer are you running? Most of the time I find the odd click generated by my forgetting to open out the buffer after recording guitar or something. Perhaps try it with the buffer at it's largest setting and see what happens...
     
  6. sonnykeyes

    sonnykeyes Senior member

    What audio hardware are you using? I have to use Digidesign HD2 at the studio here, and when I play Logic through it it behaves terribly. At home, same computer (with less memory!) and a Presonus Firebox and hardly a stutter.
     
  7. Wavetable Jackson

    Wavetable Jackson New Member

    I'm running the buffer at 256 and Small. I had it set higher and at Medium. The lower setting has removed a chunk of the clicking artifacts, but not all. I suspect I'll have to re-play a couple of those sections. I'm still trying to get a fuller feel for what Logic "likes" in different situations.
    As for audio, I'm running the main audio Out from a small Mackie mixer and the USB out of a Korg TR61 through a Lexicon Lambda. Its been nice and stable for a couple of different projects, so I'm satisfied that the Lex is living up to their good rep.
    You always have to learn how to impose the right 'spin' on YOUR particular setup and can it get fussy? Is (insert most hated politician or pop star here) a revolting, ring-tailed baboon? I'll keep digging! I've already become so used to the Mac/Logic running smoothly, I was downright surprised to have this pop up at all. Good suggestions all around.
     

Share This Page