Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Command + Save = CRASH?

Discussion in 'Logic 9' started by charlie, Oct 17, 2009.

  1. charlie

    charlie Senior member

    Just want to see if this is a bug related to a specific project I am knee deep in now using Logic 9.0.1 (and now 9.0.2,) OR if this is a real bugger!
    I can duplicate this simply though it seems to happen more if I am in the Piano Roll Editor OR, engaged in Automation of a track.

    While in one of the two modes mentioned above, i wish to save where I am at to be safe...
    I hit CMD + S to save my project and: Logic just disappears and the Error Message dialog pops on asking me to fill out what happened leading up to the crash, (which i always do,) and I re-open the program.
    Note: there is NO "Crashed" save version of the file in my projet folder. It appears that Logic does not have time to save in time... :brkwl:
    When Logic boots back up, I'm screwed and have to re-do everything I did since the last save.:mad:

    This also happens upon quitting Logic (CMD + Q), it asks me to confirm the save but pops off as described above.:eeek:

    My work around seems to be selecting Save AS from the File pull-down menu and manually save "over" the file I have or save as a new file.

    Anyone else out there having SAVE issues?
  3. Markdvc

    Markdvc Administrator Staff Member

    That sounds pretty bad Charlie. Is it related to any particular project or projects? Have you tried letting Logic 9 create a new project from scratch, adding a few bits and pieces - one or two VIs and effects, play some Midi in, then save? I would suspect that either some projects of yours are corrupted, maybe some AU isn't playing ball, your Audio HArdware/drivers might be causing problems (althought those may make their presence felt through KPs), or your Mac has some other problem. Rest assured, if this was the way Logic 9 was for everyone, the internet would be straining under the weight of complaint messages.

    My suggestion would be, if you can't trace it back to some corrupted project, either start removing components one at a time and see if you can track a culprit down, or, if the worst comes to the worst, seeing as you have a Mac Pro, replace your system HD with a fresh one, install OSX, bring it up to date, install logic, bring it up to date (including pro app support, QT etc.) and then try creating a few new projects and build everything back up, testing as you go.

    hope it works out

    kind regards

  4. Colin Shapiro

    Colin Shapiro Senior member

    Another suggestion:
    Your Environment may be corrupted. A friend had repeated crashes like this and we found that he had duplicate objects which had possible come in from importing stuff from other songs.

    Check each layer to see that the Environment is okay....
  5. charlie

    charlie Senior member

    Thank you, yes I believe this is a project related issue as well.
    I actually did find a couple of plugs (a PSP MixSaturator 2 and another Plug that escapes me right now,) that seems corrupt. Removing those has "so far" alleviated some other issues I was having. I will do further trouble-shooting after my deadline. Thank you though!
    And Colin, the suggestion re The Environment is a great one. I'll start there as soon as I free up.
    I will post what I find.

    Thanks Again, Guys!


Share This Page