Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Connecting and using Focusrite Saffire PRO 14 with logic express.

Discussion in 'Logic 9' started by Pallamannen, Sep 9, 2012.

  1. Pallamannen

    Pallamannen New Member

    Hi!

    I have no real experience with recording and making music but got Logic Express 9 a while ago as well as the Focusrite Saffire PRO 14 audio interface. My problem is that I can not get Logic to source(?) the sound from whatever instrument that I have connected to the interface, instead it picks it up from the mic on my macbook pro. Could someone please give me a walkthrough of how to set it all up, that a novice can understand?
     
  2.  
  3. Pallamannen

    Pallamannen New Member

    On more thing

    I forgot to mention that I have tried plugging my headphones into the interface but I am not getting no sound there either. All the cables and mics and such are ok.
     
  4. CSeye

    CSeye Senior member

    Hello,

    Is your Saffire interface selected in the Audio MIDI utility?
    (Applications Folder> Utilities>Audio MIDI Setup app)
    You may need to click on the Window menu when the AM app is active and select Show Audio Window.

    Once selected in the AM app, you should then be able to select your preferred input.

    The attachments show the Apogee One selected as the audio interface in the AM app, with Input 1 selected.

    Hope this helps.

    If I might add, that it would be helpful if you posted your system specs as requested in #4 here: http://www.logic-users-group.com/index.php?q=forum-rules-terms-of-use.html
     

    Attached Files:

    • AM.png
      AM.png
      File size:
      53.9 KB
      Views:
      18
    • Input.png
      Input.png
      File size:
      13.5 KB
      Views:
      4
  5. Pallamannen

    Pallamannen New Member

    Hi!

    I did what you said and the MixControl is telling me that the interface is connected, but instead of picking up sound from the wrong input it is not picking up no sound at all. The mic and cable and all that is working properly, I tested them just now. Do you have any clue at all? :confused:

    MacBook Pro 7,1
    Ram- 4 GB
    Mac OS X 10.6.8
    Logic Express 9
     
  6. CSeye

    CSeye Senior member

    Pallamannen,

    When you say that the mic and cable are working, please explain how you know that? Describe what you're doing: plugging it into an amp? Seeing signal in an LED meter?

    Open your System Preferences>Sound. Hit the Input button. Select the Saffire. Does the Sound panel meter register input?

    Is the mic a condenser that needs the phantom power switch on?

    What happens if you select a different input in Logic?

    Also check my PM.
     
  7. Pallamannen

    Pallamannen New Member

    Hi again

    My mate plugged them into his interface and recorded things and it all went great. I am fairly certain that he did not use a preamp or anything like that. :S
    He uses a completely different program and interface though, and he runs it on a PC with Windows, that is why I am asking questions here and not him ^^

    http://www.zzounds.com/item--STUB1
    I think that this is the mic I have got.

    If I start up Logic without the firewire cable connected it pops up a sign saying:
    The previously selected audio interface is not available.
    The built-in audio inputs and outputs of the computer will be used instead for this session.

    That is the built in mic and I can also manually change input to built-in input.

    Thanks alot!
    Pallamannen
     
  8. CSeye

    CSeye Senior member

    Very nice microphone. :thmbup:

    So you're able to record voice or hand claps via the built-in mic?

    Assuming that you've installed the most current software drivers for the Saffire, then I'm wondering about which version of LE.

    You indicate LE9 with OSX 10.6.8.
    You should upgrade LE to the latest version 9.1.7
    http://support.apple.com/kb/DL1015

    That might fix your problem.
     
  9. Pallamannen

    Pallamannen New Member

    Hello!

    I did as you said earlier and changed my system preferences, and before I tested if it worked I went into the Logic preferences as well. They had reset but now I changed them and the recording works a treat!:D:D

    Thank you for all the help, you are great!
    With this set up you will hear me on the radio any day now, so keep an ear out :D haha
     
  10. CSeye

    CSeye Senior member

    You're very welcome.

    I'll be expecting an autographed concert poster and promotional copy of your CD.:D
     

Share This Page