Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Control surface questions

Discussion in 'Logic 9' started by hunter_aran, Apr 18, 2013.

  1. hunter_aran

    hunter_aran New Member

    Hi everyone,

    I am new here and I was referred to join the group by Doug Zangar. Thanks a lot, Doug! Anyway I have some control surface questions I hope you can all answer, especially since during my searches on the site I noticed many of you use the same or similar gear.

    I am using 10.6.8 with Logic 9.1.8 on Macbook Pro 2.3 i7. I use several different controllers/control surfaces depending on where I am and how much gear I feel like pulling out. I have a Korg NanoKontrol2, Novation 25 Sl MKII, and Yamaha Motif XF8 with the FW16E firewire card. This is my first time really trying to hook up control surfaces like this so sorry if anything is super obvious (I obviously didn't get it). I read the control surface documentation for Logic 9 and searched this forum pretty thoroughly over the last few hours and didn't really find the answers I needed.

    First, I got the NanoKontrol2 hooked up using the .cs template from Korg directly. It works great and is really handy! Now if I don't happen to be using it, I get this really annoying message every time I start Logic and when the computer wakes from sleep: "Device "NanoKontrol2" is assigned to MIDI port "blah blah blah" which is not present". Then it says to make sure it's connected and if it is to "reset MIDI drivers". That's fine but what if I don't want to use it right now? Am I stuck having these messages keep reminding me this as if something is malfunctioning? This also happens when I use my Motif and don't use it the next time I open Logic. I just figured that I could install various control surfaces, set them up, then use them as needed or not without problem and Logic would recognize what I have connected (or not). Logic also shows the color-coded stripes on the track headers as if the device is there when it is not, which I don't understand.

    Second, has anyone have a template or advice on how to set up Logic for use with the Motif XS/XF Master Mode? I have the Motif addressing internal sounds and I set up several of the Master Mode zones to use the sliders and performance control buttons to mix and mute Logic's software instruments I have loaded to separate tracks. All Logic seems to understand is that ANY slider I move on the Motif controls the only track I have selected at the time. The muting thing isn't working either but I found out I needed a software update for the Motif, which I did do, but have not tested yet. I am assuming the Motif sends out MIDI CC data from the sliders/knobs/buttons but that Logic does not know where it's supposed to go...? Again, I have never done this before so I really don't know what I need to do to get that working.

    Lastly, I got the Novation SL MKII for portability and set up Automap. I really didn't like the fact that it is separate program running next to your DAW, that it wraps your plugins, and that Logic seemed less responsive than before. All I really want it to do is to control the mixer with the sliders, pan knobs, transport, track mute, solo, record... just basic stuff. After uninstalling Automap after un-wrapping my plugins, I read I could use just "Advanced Mode" to set it up. I am also not sure what exactly I'm doing here because even with the correct Novation drivers this thing does not show up at all in control surface setup. What am I missing? Other have done this so clearly it is possible but no one seems to have a template or .cs file or whatever for this simple setup. Oh and there's this really annoying C-2 off message this thing sends every few seconds that pops up in the transport window for some reason... :confused: I really like this little guy and hope I don't have to sell it and get a worse-feeling mini keyboard.

    I hope some of you here can help or at least point me in the right direction.

  3. mt100uk

    mt100uk Senior member

    I'm not sure about any of your specific hardware but the incoming note thing is usually caused by a control surface midi message not being filtered out by logic. Essentially it means you have something connected to, but not setup in, logic (probably the novation.)
  4. hunter_aran

    hunter_aran New Member

    Yes I found out the C-2 OFF message is the Novation controller's way of communicating so that the program know its connected and working.

    Ok well one thing I did figure out is that apparently I did not clearly understand the difference between the control surface setup screen and the controller assignments. :redface: I thought that you have to get your device set up in the control surface setup screen THEN you go to the controller assignments to see or edit all the functions. Unless I am mistaken (please correct me if this is wrong) the controller assignments are independent and show up as that light blue line on the track that has the control assignment(s). The devices you setup in the controller setup have to be supported and installed and then you can't really edit the preset commands but can add to them using the learn function (controller assignments). The environment seems to be a way to change some things but I want to set my devices up so they work for all projects.

    Still no luck on the annoying messages telling me that my devices are not connected (Yes I know they are not) every time my computer wakes from sleep or when Logic is opened.

Share This Page