Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Control surface setup every time I open logic 9

Discussion in 'Logic 9' started by brucepierce, Aug 21, 2012.

  1. brucepierce

    brucepierce New Member

    Hello again,
    I have asked this question before in a post with other issues...I'll run it past you folks again...
    I have a mackie mcu pro and an extender for control surfaces running logic 9...
    Each time I close and reopen logic I need to reset the ports for both control surfaces, is this normal to have to setup these devices each time I open logic?
    Any ideas are appreciated...
  3. georgelegeriii

    georgelegeriii Senior member

    No it's not normal.

    You could try deleting the Logic control Surface plist file, that might do it. Also have you tried to repair disc permissions?
  4. Gravity Jim

    Gravity Jim Member

    Are you running Mountain Lion? Mine did the same thing when I was still trying to make 10.8 work.
  5. paulnajar

    paulnajar Senior member

    More Info please Bruce.

    How are the mcu's connected? Do you have other midi devices connected? Are you running other software in the background when you boot logic? If so what?
  6. brucepierce

    brucepierce New Member

    Hey Guys,

    Thanks for the input...So far I have removed the original file and I have had a myriad of things happen when resetting up the 2 control surfaces...not all bad, at this point ( after a few new cs files ) I have the MCU Pro coming up recoginized with the correct port (1) then I power on my Extender Pro and it is added and on the correct port also (2) so....I guess in theory its another workaround but it takes me a step closer to being able to not have to assign ports...maybe there is a pecking order to the power on process? And to answer the other questions I'm running Snow Leopard and I have no other software running or any MIDI devices in use.
    Thanks for everyone's input...much appreciated

  7. paulnajar

    paulnajar Senior member

    OK Bruce,

    I'm assuming you've connected your MCU to computer via it's USB port and then you have the XT connected to the MCU via 5pin midi cables?

    next time you have Logic open and everything assigned and working how you would like it, open the Control Surface Setup window and from the local new menu make sure "Automatic Installation" is NOT ticked. Then quit Logic and reboot and the Control surfaces should just work without anything odd happening.

    By unticking this setting you're telling Logic to NOT look for attached control surfaces every time the software boots up.

    Hopefully your existing (correct) settings will just remain correct.

    Let us know how you get on.

    Kind regards
  8. brucepierce

    brucepierce New Member

    Hi Paul
    Yes that's correct for the setup..I tried what you had suggested and that seems to have cured my problems...Thanks to all of you for your assistance

Share This Page