Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 Copying MIDI region, pasted version doesn't want to snap to bar beginnings

Discussion in 'Logic 8' started by MrTacos, Oct 2, 2009.

  1. MrTacos

    MrTacos New Member

    I have different versions of this problem a lot, but I just did a simple version of it that I think may be the common case:

    1) I hav a 4 bar cycle set up. I record some midi data in there
    2) It's exactly four bars, because I was in cycle record, and I selected a four bar cycle range in the top ruler, which when Snap is 'Smart', snaps to bars, right? I make some tweaks to the notes with the piano roll editor.
    3) I copy said MIDI region with Cmd-C
    4) go to next track, paste region with Cmd-V. region appears where the song position line is.
    5) I try to drag it. Snap is still on "Smart". Despite the fact that the source region was exactly four bars long and started from 1.1.1.1, this region does not snap to the beginning of bars, it wants to snap to some point slightly ahead or behind the bar boundary?
    6) However, if I move the song position line to 1.1.1.1 and paste, the region lines up there, the SPL still pastes the region wherever it wants.
    7) Similarly, if I turn off snap I can of course drag it anywhere.

    So...what is happening here? Is there like an embedded 'anchor' point or something for MIDI regions that I might be messing up? I've also noticed this when trying to duplicated a region in one track, the ends of the regions won't snap together, even though the first region is definitely on the bar boundaries (say I created it by Split By Locators after setting locators to match bar boundaries).
     
  2.  
  3. Markdvc

    Markdvc Administrator Staff Member

Share This Page