Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cycle Mode

Discussion in 'Logic Pro X' started by mustbthemix, Aug 19, 2013.

  1. mustbthemix

    mustbthemix New Member

    Hey everyone, I'm having a slight problem playing my project from the beginning of song. I have cycle mode enabled @ the 5th bar, the 1st 4 bars is the intro. When I hit the play button the song starts playing @ the 5th bar and not @ bar 1. Can someone point me in the right direction as to adjusting a setting. I'm new to Logic Pro x coming from Cubase 6.5. Getting use to the New Enviroment!.......Thank you!! :)
     
  2.  
  3. Eli

    Eli Senior member

    Why not just turn off cycle mode? Or start the cycle from bar 1?
     
  4. mt100uk

    mt100uk Senior member

    Hi, this is the normal behaviour, for better or worse logic always starts playing from the beginning of a cycle if it is enabled. The standard key command of "c" will toggle the cycle on or off.
     
  5. mustbthemix

    mustbthemix New Member

    Ok, thanks guys! I was hoping that there was a setting to fix this. When I'm recording different tracks within the loop is ok. But when I want to record and hear the song from the beginning I guess I have to quickly hit the loop function button to keep from looping to the beginning. Cubase has this feature that let's you keep loop enabled and will start the song from the beginning, but only loop the region that is highlighted. Not a biggie! Thanks again for your assistance!;)
     
  6. Antiphones

    Antiphones Member

    This is one of those things where if you've never really used cycle in Cubase you don't know how much better it is than Logic's cycle. I mean IMO the Cubase cycle is way better, Logic's cycle mode is very limiting. Yes you have to switch it on while playing. Not great. But, Logic is just SO great in almost every other way that I'd never go back to cubase. Cycle mode is one of Logics quirks - or so it seems if you have know better cycle modes :)
     
  7. bayswater

    bayswater Senior member

    Maybe I'm missing something but it seems to me there are a few simple ways t do this.

    1. Can't you just assign a key to the "Go To Beginning" Command? That takes you back to bar 1 regardless of the loop start position.

    2. If you want to start somewhere other than bar 1, put a marker there, and assign a key to "Go to Marker Number X".

    3. If you don't need to go too far back from the loop start, hold the rewind key down.
     
  8. Eli

    Eli Senior member

    To the OP, welcome to Logic :D

    Switching DAWs always inherently involves soem sort of modification to your workflow. Let go of how you are used to it working and learn just one single key command. C. That's hit. Just hit C to toggle cycle mode on/off. I have no doubt it is different than in Cubase, but this is what you need to do in Logic.

    As an alternative, if you REALLY want to keep cycle mode on, you could use the marque tool. Just click with the marquee tool wherever you want playback to begin from and playback will start from there. A marquee stripe supersedes the cycle in terms of playback priority. Assign it to your alternate tool,then all you need to di is a quick single command click where you want playback to begin from.

    Although this is a great technique, and will easily achieve what you want; I would suggest getting familiar with toggling cycle on/off as well. It's a fundamental part of Logic's intended workflow.
     
  9. mustbthemix

    mustbthemix New Member

    You guys are GREAT!! Thanks for the workaround. I will definitely utilize your tips. I was just wondering if I was overlooking something. LPX is so cool, all the hidden features are manifesting!!
     
  10. mustbthemix

    mustbthemix New Member

    Hey guys, I just solved my problem. You go to "Navigate" scroll down to "Play Button Option" and check/uncheck next to "Play from cycle start."

    Thanks Again for your help!!
     

Share This Page