Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Deleting Flex Markers

Discussion in 'Logic 9' started by Rafa, Aug 25, 2009.

  1. Rafa

    Rafa Senior member

    Every now and then, Flex will misinterpret a single note and divide it it into two notes, no biggy, but when I try to delete the unwanted markers they always mysteriously re-appear when editing that note.

    The markers always re-appear over the lighter grey line (a transient line probably), how can I make it stop? How can I make that flex marker disappear from the face of my session?
    (I'm having some trouble trying to get my head around the different shades of grey in Flex markers. The dancetech tutorial really helped me, but I still feel like a toddler.)

    Thanks for all the heroes at LUG
  3. Rafa

    Rafa Senior member

    It's working fine now in some sessions. It's kind of weird when problems get solved all of a sudden with no real effort on your part, but anyway i'm glad!
  4. Rafa

    Rafa Senior member

    By now I'm fully aware that this thread bears no interest to anybody in this Forum, however I decided to keep sharing my experiences anyway.

    I had problems with re-appearing flex markers, that were previously deleted. Well, I just found out that they don't re-appear if i choose the "right" note to stretch. What I mean is: if there are 3 tracks in a group, there is one which will always re-create deleted markers, and another that respects its master's wishes and moves everybody together as one happy note!

    You must find the right one - you just look at them and think: "Hummmm the force is strong in this one, maybe it will move without re-creating markers."

    Better I'm getting with this Flex thing
  5. sandbags

    sandbags New Member

    I'd encourage you to think less "nobody cares" and more "nobody has anything sensible to add".

    Since Flex is new it's unlikely that there will be lots of people intimately familiar with it's problems and their workarounds. Kudos to you for carrying on and documenting what you see anyway.
  6. Rafa

    Rafa Senior member

    Thanks a lot sandbags, you just made my day!

    By now I've worked a little system to get around this issue. I edit the note first, and then I delete the unwanted markers. I know it sounds trivial, but it took me a while to figure it out.
    For instance, if you move a note which is divided in half by a boogie flex marker, the note will split into two notes. After you put the first one in place, delete the boogie flex marker and the splitted note becomes one single note, as it should be.

    This really improved my editing workflow!
  7. funkyappledog

    funkyappledog New Member

    Can i add,your issue has been a paramount issue for me too.But was still finding workarounds. Its probably in the help but can you explain how you delete unwanted markers.
  8. Rafa

    Rafa Senior member

    Double clicking over the marker will make it disappear. Or you can control-click over it, and a dialog box will open with two options: "delete marker" and "set note to neutral position".

    Important note: In grouped tracks you have to delete the markers individually one by one for every track in the group, same thing with setting notes to neutral position.

    In my country we call this a: "pé no saco" :brkwl:
  9. funkyappledog

    funkyappledog New Member

    O.k Great & Thanks will do.
    Yeah i have been trying to pull a sloppy rhythm section closer together and have grouped the drums.I can tell you sometimes you flex a beat and the whole file seemss to just move too in an un-flexy way,easily fixed but one thing is for sure,keep you ears and eyes wide open.
  10. UnoBars_Dread

    UnoBars_Dread New Member

    Absolutely right, and the solution to your problem lies within editing the transients. Simply follow these steps.

    1. Select/Highlight the region you are working with
    2. Open Sample Editor from the 'Window' menu
    - Your Audio File will now show up visually. The white lines in the Sample Editor are the same 'ghost' lines in your flex view.
    3. Turn on Transient editing mode from the 'View Menu' (⌘T)
    4. Delete any unwanted transient markers by double clicking them and they will disappear in Flex


Share This Page