Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Dotted length wont go away, in midi and audio editing

Discussion in 'Logic Pro X' started by madelefant, May 24, 2016.

  1. madelefant

    madelefant Senior member

    Does anyone know why, when editing audio with scissors, and in some cases even with midi, Logic Pro shows everything as a dotted length? I noticed that with a midi 4 beat region that showed as 1 bar, but with a dot on the end, after repeating it multiple times, it was drifting to where it wasn't lining up with the bars. I was able to fix this in the Piano Roll. But still in editing audio with the scissors, it keeps showing everything as if the end a dotted length. I've turned off all quantizing.
  3. madelefant

    madelefant Senior member

    Wow. So I just did some editing to audio regions in the same project. Very careful to only be editing the audio. Mostly repeating versus to fill in a song with loops of the same verse structure. Low and behold the midi 4 beat region that I was using as a timing element had changed the notes to dotted notes and slightly out of time. It's not possible this was some small edit accident. Every thing I did was moving full bar or even verse regions. Nothing that would put something off by such a marginal amount.
  4. madelefant

    madelefant Senior member

    Yea so in editing, Logic had again changed 1 bar repeated midi region (as copies) into slightly less than a bar in length, with out even editing the region itself. As best I can figure, the issue is if you go in an repeat a midi region and in the region repeat section automatic adjustments is selected, then the regions are some how changed base on other edits. I'm not talking about edits to tempo, time signature or divisions. None of that was done. I'm talking about dragging and copy audio regions Absolutely amateur garbage. They shouldn't call this a pro app. I'm completely disgusted.
  5. volovicg

    volovicg Senior member

    The point after the tick value means that you have adjusted the region length ( by an edit) to be between two tick values. A tick is 1/960th of a beat. This happens if you zoom in very tight and make cuts when you playhead snaps to samples instead of ticks or lower. The quick solution is to open the event list ( press the up arrow to show regions) and adjust the tick value to remove the dot ( just go up, then back - ie. 3. 2.1.7. move the 7 to 8 and back to 7 again and the dot will go away with the region end then ending on tick 7 instead of between 7 and 8 - Check your settings and make sure your snap mode is set to automatic, bar, beat, division or tick but nothing below that. Also - if set to automatic don't zoom in to the max. if you do zoom in to the max, set the snap mode to ticks and adjusting region boundaries which will then force snap to the tick, but you playhead resolution maybe at the sample level so you have to watch the location if you are zoomed in that tight. This "feature" was introduced when logic introduced sample accurate editing capabilities at the sample/frame rate etc. The attached shows snap to grid with smart vs ticks at high level zoom affect editing. Hope this helps
    BTW - make sure you have set snap regions to absolute mode so there is no confusion between this issue and moving regions by relative position instead of absolute.

    Helpful hints:
    snap mode automatic - just zoom out a bit.
    snap mode tick - zoom in as close as you like ( but watch the playhead if you use that for cuts/edits)

    sample accurate editing1.gif
  6. CSeye

    CSeye Senior member

    You always provide detailed, and to-the-point information.
    Thank you.
  7. volovicg

    volovicg Senior member

    Thank you!
  8. madelefant

    madelefant Senior member

    Very nice of you to add that level of detail (volovicg).

Share This Page