1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Drum Programming Question: Logic Newbie

Discussion in 'Logic 9' started by Arzlo, May 4, 2010.

  1. Arzlo

    Arzlo New Member

    Hello,

    I'm a Logic newbie and recently upgraded to Logic Express 9 from garageband. I'm trying to get my head around drum programming using cycle mode am running into problems when trying to overdub. I'm using cycle mode and recording into a specific region. I come from a hardware drum programming (yamaha motif) backround and like to record my drums using a loop based method (cycle mode.

    1. I usually record my kick and snare and hit stop and then go back and overdub hi hats. Some times when I go back into the piano roll it only shows the hi hats and not the original kick and snare, however I can hear the snare and kick. Is logic creating a take folder for the hi hat overdub? I don't see an arrow or option to review takes like I would in audio. Is there a setting that will allow me to overdub continuously even after hitting stop after the first take?

    2. When recording in cycle mode in a specific region I find that sometimes the regions become grouped together automatically and previous regions areas become erased. Is this due a midi note falling just before the one beat?


    3. When I finish recording a drum beat it automatically loops the region to the right continuously. Is there a setting to prevent this from happening?

    4. Where can I find more information about flatten, merge, and capture last take? I'm sure some of my issues mentioned above must have something to do with these??

    If anyone has any answers or can point me in the right direction that would be great!
     
  2.  
  3. Eli

    Eli Senior member

    Hi there,

    Congratulations and welcome to the wonderful world of Logic.

    To answer your questions:

    1. Check out your Project Settings. Go to the Record section and look at the area for MIDI recording options. You'll probably want to choose either merge with selected region or merge when in cycle mode. This way as the region loops and you add new parts they will automatically get merged in on each pass. No take folders or flattening or merging to worry about.

    2. Yes it's probably that. Although your description is a bit confusing. See if changing the setting mentioned above affects this behavior.

    3. You have the default thru setting for loop enabled in the region parameter box. With no region selected, deselect the loop checkbox in the region parameters. It won't loop automatically after that.

    4. The manual.
     
  4. Arzlo

    Arzlo New Member

    Thanks Eli! I changed the settings and it seemed to work for me aside from #2.
     
  5. becker7cr

    becker7cr New Member

    Overdubbing with Ultrabeat

    Hey, I just came across the same issue. What worked for me, is once you've clicked on loop region, you can right click again, go down to "convert" and there will be a selection towards the bottom that says "convert loops to real copies." THen, when you cycle the selected regions you can record over you foundation adding effects.
     

Share This Page