1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Editing Snap problem

Discussion in 'Logic 9' started by jpcesar, Mar 19, 2012.

  1. jpcesar

    jpcesar New Member


    I have a really beginner question. I'm struggling a bit with editing because when I'm cutting and pasting, and dragging or reajusting audio tracks they do not snap to the nearest whole beat. Even if I select the option snap to beat I'm not getting what I want.

    I'm forcing to do a lot of zooming, and discover things that there are not properly aligned with the beat.

    Is there any shortcut to make the snapping? I'm feeling like crazy now :S

    On Sonar X1 I just selected snap to whole , or 1/2 or 1/8 and I could achieve what I wanted.

  3. georgelegeriii

    georgelegeriii Senior member

    Logic has "smart snap" which changes resolution depending on your zoom level.

    Check it out in the manual to get a better idea of how it works and how to use it better. It's under the menu that says "help".
  4. Eli

    Eli Senior member

    I've never been a big fan of the Smart Snap functionality. I generally like to know specifically where things will be snapped to. You have the option of choosing a fixed value rather than "Smart" mode.

    Attached Files:

  5. forgetr

    forgetr Member

    In the Snap menu, check "Snap to Absolute Value." That will do what you want.

Share This Page