Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X El Capitan.... Anyone Yet?

Discussion in 'Logic Pro X' started by HKC, Oct 15, 2015.

  1. HKC

    HKC Senior member

    Hi there
    Has anybody installed El Capitan yet.
    I am very tempted because I'm about to start a new rather long running project.

    All the Best
    HKC
     
  2.  
  3. HKC

    HKC Senior member

    Hmm Native haven't solved their compatibility problem yet. I will need Kontakt so I guess I have to wait. Hopefully this won't become a problem further down the road.
    Please reply if there are other issues.....
     
  4. Peter Ostry

    Peter Ostry Administrator Staff Member

    There is really no reason to upgrade right now. You can do it later, after the test dummies (= impatient users) have learned their lessons, the system became (hopefully) stable and the hardware and software issues were solved (or not).
     
  5. HKC

    HKC Senior member

    You're of course right but I find it that it's only fair that everyone takes their turn as test dummies. This time it won't be me.
     
  6. EdgarRothermich

    EdgarRothermich Senior member

    No ... you go first ...
     
  7. bayswater

    bayswater Senior member

    There are a lot of posts in various forums citing problems with 10.11, more than I've ever seen with any other OS X versions. I've had a load of messages from VI and plugin suppliers saying to wait. Seems Apple has upped the security game and rendered a lot of things incompatible.
     
  8. HKC

    HKC Senior member

    I will definitely wait. Thanks for the replies.

    Henrik
     
  9. Billious

    Billious Member

    Ignoring incompatibility with 3rd party plug-ins, softsynths, etc. for a sec, does anyone know how well Logic X and MainStage run in El Capitan on their own?
     
  10. stuartf

    stuartf New Member

    Native Instruments VI and Effects pass validation in the latest 10.11.1 public beta which seems pretty stable. The full release should hopefully be due pretty soon

    I upgraded before reading the email from NI. Which was unhelpfully sent at the same time as El Capitan was released. They must have known much earlier. I'll be generous and suggest non-disclosure didn't let them announce this issue ahead of release.

    Izotope stuff crashes validation due to a missing xml library in /usr/local but this can be fixed by copying in the file from the system library.

    Other than that Logic seems as stable as always on this release but this view is only after a few hours use in the last weeks and a bit

    Stuart
     
  11. HKC

    HKC Senior member

    Please keep me updated if Kontakt becomes stable in a non beta version.

    HKC
     
  12. Jay Asher

    Jay Asher Senior member

    I waited until 10.11.1 but now all is fine, including the following:

    RME HDSPe-AIO
    MOTU MIDI Xpress XT (with the beta driver)
    Vienna Ensemble Pro 5

    Software Instruments:
    EW Play, Kontakt, Arturia Moog Modular, Spectrasonics: Omnisphere, Trillian, Stylus RMX; Linplug: Albino 3, Crono X3, Octopus; UVI Workstation

    FX:
    All UAD 2 plugins, QL Spaces, All McDSP, Eliosis Air EQ, All PSP & Sonalksis
     
  13. HKC

    HKC Senior member

    I think I will give it a go. The things that you mention are working for you are pretty much the same as the ones I need to work.
    If RME, Play, Kontakt and UAD2 work then I can do without most of the competition.
    What I always worry (and it's based on experience) is when I start a long running project that some of the plugins that I use will cease to get updated. This has happened in the past with OS updates and to avoid that I think that may as well jump in now.

    HKC
     
  14. HKC

    HKC Senior member

    Hi again
    Everything seem to work here. Some of the Sonnox plugins didn't validate at first but after rebooting they all passed.

    Have a nice day
    Henrik
     
    bambony likes this.
  15. rainguitar

    rainguitar Member

    In few weeks I will be taking delivery of a new MacBook Pro. At present I have a three-year-old MacBook Pro running Yosemite. This machine is failing and must be replaced, but that also means that my time machine backups are all Yosemite. It is my preferred operating system because I run a lot of 3rd party AU plugins some of which are not currently compatible with El Capitan. Yes I know that the recent 10.11.1 update is supposed to fix that, but obviously some problems still remain.


    These are the 3rd party AU plugins I currently have installed and validated within Logic 10.2. All of them are the latest updates as of about a week ago.


    Native instruments Komplete 10 plus Scarbee J Bass, Strummed Acoustic and Razor. Zebra 2, Bazille, Zebraette, Uhbik effects, Waves Silver, Sonalksis Free G, Izotope Ozone 5, Amplitube 3, Melodyne singletrack.


    My new computer will ship with El Capitan pre installed. What I’m hearing is that there may be firm-ware issues that will prevent the new MacBook Pro from running Yosemite, or at least the version of Yosemite that’s installed on my current computer. This may have something to do with the fact that my current machine created the time machine backups and is a few generations earlier than the new machine. It was released in 2012.


    I also don’t have the option of reinstalling Yosemite from the apt store because it was never originally downloaded from there.


    My question is this is there any way I can force the new machine to completely revert to my time machine back up, including Yosemite? Sorry for asking this question on this site but I’ve learned that the Apple advisors, even the senior pro app advisers, often can't or won't answer questions related to 3rd party plugins.
     
  16. stuartf

    stuartf New Member

    The new machine will almost certainly need new drivers to function that will only be provided with the supported OS.

    At best with Yosemite your new Mac Book might boot and some features may not work or it runs really slowly and occasionally just reboots itself randomly. The most likely thing is that it will simply not boot and/or panic during booting.

    As far as I know they would be no way to force the Time Machine backup to recover itself onto an unsupported platform. System files are not always saved with the backup. There is a hidden advanced option in Time Machine to enable that.

    Of your list I have the following AU and they validate on 10.11.1

    Native instruments Komplete 10, Razor. Zebra 2, Bazille, Izotope Ozone 5, Melodyne singletrack. I also have some individual Waves plugins and they are all fine on version 9

    For Ozone 5 I had to do the XML library copy into /usr/local to get it working on 10.11.0

    Stuart
     
  17. rainguitar

    rainguitar Member

    Thanks Stuart. I guess I'll need to contact izotope about how to do the XML library copy. I'll probably upgrade to Ozone 7 in the new year anyway but, for the time being, it would be nice to have Ozone 5. The other unknown is Amplitude 3. Then again Amplitude 4 is in the works and one assumes that will work with El Capitan. Both have upgrade tracks I believe. Would there be any advantage to me upgrading to El Capitan now or should I wait for the new machine. I'm not doing a lot of music production at the moment. My main gig is writing science fiction.
     
  18. stuartf

    stuartf New Member

    Process for XML Library fix is on this page. It may not be needed with 10.11.1 so try validating first

    http://machow2.com/el-capitan-problems/

    In your position I would wait for your new machine and stay on Yosemite. That way you still have something you know is working!

    The weirdest El-Capitan bug I have experienced is that my Time Machine backups (which are to network drives) do not work if my APC UPS is plugged into a USB port on my MacPro. It seems others are experiencing this and its still a problem in 10.11.1
     
  19. HKC

    HKC Senior member

    And I can add that my Sonalksis stuff works fine.
     
  20. BambiWolf

    BambiWolf New Member

    Hei, hei!

    I am working on OS 10.6.8 and Logic Pro 9 with little issue, but have decided it is time to upgrade to make all my devices & programs compatible, and I'm getting ready to start a long term recording project - so thought this to be a good moment to upgrade. I wanted to go with Yosemite but missed my opportunity. Now Apple says I can't have it - only El Capitan - or older programs they could give me code for but ones that are not compatible with Logic Pro X (of course).

    SO.... I want to know if El Capitan & Logic X are working together. I am on an iMac i5 (2010) with an EIE Pro Interface, PRO MPA II, and at this time the only plugin I'm using is Melodyne. (very simple system) I plan on purchasing Ozone & Native Instruments in the near future.

    Any advice would be greatly appreciated!

    Nervous,
    Bambi Wolf
     
  21. bayswater

    bayswater Senior member

    I'd say if you are about to start a long term project, this is the not the time to upgrade.
     

Share This Page