Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error While trying to Synchronize Audio and Midi

Discussion in 'Logic Pro X' started by thmusic7, Sep 15, 2014.

  1. thmusic7

    thmusic7 New Member

    Hello everyone. I have a late 2010 iMac i3 upgraded to Mavericks 10.9.4.

    For the last two years I have been getting this error when Using Logic Pro 9, recently upgraded to Logic X:
    "Error While trying to Synchronize Audio and Midi" When ever I get this message, I get a bunch of popping and clicking noises and my COMPUTER RUNS SLOW, even when I try to look at youtube or listen to iTunes. It tells me my sample rate is recognized at 40973 and to check conflict between Logic and external device. Don't know how to do that.

    Some of the plugins I have are Trillian Bass, Kontakt 5, Focusrite mixers, Bass Station, Addictive Keys, etc. I also have a scarlett 2i2 audio interface, but it even does it when the interface isn't plugged in.

    I know every little about audio DRIVERS, and the Coreaudio whatchamajigger. I even tried to get help from the so called apple "genies" but to know avail. Does anyone have a "Simple yet effective solution to what I can do about this. Even if its not so simple, please be as plain as possible. I love music but I'm no tech head. Thanks.
     
  2.  
  3. Atlas

    Atlas Senior member

    The basic issue when this happens is that Logic is either not getting audio data at the sample rate it expects, or the sample rate is fluctuating. Depending on the specific cause, here are some tips for resolving this:

    In most cases, Logic can set the sample rate for the audio interface, but sometimes this is not possible. Check the sample rate for your audio audio interface and make sure it matches Logic's setting. If the settings match, try changing Logic's sample rate to a different setting and then back again.
    If you have any devices digitally connected to the audio interface, make sure that only one device is set to be the master clock.
    If you have combined multiple audio interfaces by configuring an Aggregate Device in Audio/MIDI Setup, make sure that the devices are digitally connected, and that only one device is configured as master clock.
    If you are using Word Clock to sync multiple devices, be sure that all Word Clock connections are properly terminated.
    Choose Audio > Audio Hardware & Drivers and try increasing the I/O Buffer size.
    Try freezing tracks that use plug-ins that put significant load on the processor.
    If you are running other software or hardware that can send MTC or MIDI clock, but intend for Logic to be the sync master, turn off Auto Sync In for Logic, to prevent Logic from receiving sync externally. The Auto Sync In setting can be accessed by click-holding the sync button on Logic's Transport.
    If you are syncing Logic to another application or device via MTC, make sure that both Logic and the sync master are set to the same format. Make sure that Logic is not receiving both MIDI Clock and MTC. Also, configure the Audio Sync setting to "External or Free" in case the system is resolved to external Word Clock.
    If you using a Reactor ensemble that syncs its LFO to the song tempo, try bypassing or removing the plug-in.
    If none of the above helps, try switching to Built-in Audio. If this resolves the problem, check for updated drivers for your audio and MIDI interfaces.
    Make sure that your audio card drivers are up to date.
    Restart Logic after updating those.
    If that still not work try to deselect the core audio input/output devices (in the audio preferences), restart Logic and then select your audio input/output devices (in the audio preferences) and restart Logic again. If that fails to solve your issue, quit Logic and delete your pref files and repeat the deselect/reselect input/output devices (in the audio preferences) procedure.
     
  4. thmusic7

    thmusic7 New Member

    Thanks for your advice. I increased the buffer size as you suggested and not one time did I get popping and clicking noise. Thanks again for your advice. The only issues I have now are, that sometimes, I get an overload error causing my playback to stop. Also, a track will out of the blue, stop producing sound. I usually switch to another track and then back to original track, and that fixes the issue momentarily. Any advice?
     
  5. Atlas

    Atlas Senior member

    There is probably a discrepancy between what your project(s) are demanding CPU-wise and what your computer can actualy deliver...
     
  6. threeheavens

    threeheavens New Member

  7. threeheavens

    threeheavens New Member

    ^This is something to try, divide your track into small regions and see if it will process a piece at a time.


    The best solution probably is to change your workflow somehow. E.g. Manually move audio where it needs to be(not elequoent but it'll work), bounce your audio track so there's no plugs being used on it. You'll probably have to experiment with ideas for a while before you figure it out.

    Why is your audio out of time with your midi? I'm serious.
     
  8. thmusic7

    thmusic7 New Member

    Thanks Ill try that. It seems that as good as I believe myself to be at music, some stupid manufacturing always ends up in my lap where no one has theses problems but me. Will do as you requested. Thanks.
     
  9. Hi!Loc

    Hi!Loc New Member

Share This Page