Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 ESX24 Sampler export instrument

Discussion in 'Logic 9' started by mrvinyl, Mar 7, 2013.

  1. mrvinyl

    mrvinyl New Member

    Sometimes when I use export sampler instrument in the ESX24 all exports fine and packages up a folder with the audio files and the esx file.

    But when I re-open this in another project all I get is a tone for each sample and they won't actually trigger even though everything seems perfectly ok?

    Any ideas
     
  2.  
  3. Eli

    Eli Senior member

    I'm not sure what you mean by "when I re-open this in another project"?

    The main reasons for exporting sampler instruments are:

    A. to create a complete project folder, in case you will be opening your project on a system that doesn't contain your EXS library

    B. To save custom changes with your project or for future use, outside of your main EXS 24 instruments folder.

    C. Transfer instruments (and samples) to other systems.

    What exactly do you mean by re-open this in another project? How is this other project accessing these exported sampler instruments without them being in your EXS Instruments folder? There are generally only two ways a project can see EXS 24 files: Either from within your global or User EXS sampler instruments folder. Or from within a sampler instruments folder contained within your project folder.

    So, I am unclear on how and what you are doing exactly?
     
  4. mrvinyl

    mrvinyl New Member

    OK.

    Sampler instrument created on machine X content of sampler audio is some recorded snares and some third party drum samples.

    Need to move that sampler into a different project on machine Y

    I have tried every method going with save as, save, export instrument, save settings, save instrument.

    But... when opening on machine Y the samples are visible but will not trigger I only get the standard sine tone?
     
  5. gdoubleyou

    gdoubleyou Senior member

    Interesting, the save project with sampler instruments should work.

    Otherwise open the editor, next to the filename is a reveal triangle, that gives you the option to load file.

    Locate the files and re-save the instrument.

    If you want the instrument to always be available, you will have to move it to the sampler instrument and samples folders.

    :thmbup:
     
  6. Eli

    Eli Senior member

    Where are you putting the sampler instruments on the new machine? They need to be in one fo three places in order to be recognized. Either in the Global library applications folder, in Logic --> Sampler Instruments. Or in the same place in the User library. Or in the project folder.

    And where are you putting the samples on the new machine? It sounds to me like the instrument is having trouble finding the samples on the new machine. They don't need to be anywhere special, as long as they are discoverable by the new machine.

    You say the samples are visible on the new machine. Where exactly are you seeing them? Somewhere within Logic? Or in the Finder?

    Please confirm that you are in fact moving both the sampler instruments and the samples to the new machine. And that the sampler instruments are in the right location.
     
  7. mrvinyl

    mrvinyl New Member

    Yes I've tried putting the samples and ESX file into the sampler instruments folder in the logic project.

    [​IMG]

    Here's the instrument loaded, but all I get is the standard sine tone of the ESX no samples play ? Don't know what I'm doing wrong because its only happening when loading saved instruments. If I create from scratch inserting audio files it works and they play fine.
     
  8. Eli

    Eli Senior member

    There's clearly no instrument loaded in your screen shot. You can tell by the three empty dashes in the black bar in the center. You need to click hold in this field and manually load the instrument. You should see the instrument name there when it is loaded. It should look something like this:
     

    Attached Files:

    • EXS.jpg
      EXS.jpg
      File size:
      12.9 KB
      Views:
      6
  9. mrvinyl

    mrvinyl New Member

    Ok thanks Eli, this is really helping.
    I have got my sampler ins working now when I drop exported instruments to here /Library/Application Support/Logic/Sampler Instruments

    But I still can't get the instruments functioning or being available to select when I am dropping them into a logic project folder which I then want to move onto another machine? any suggestions? does the folder name have to be 'Sampler Instruments' and reside in the actual song folder for sampler to recognise it?
     
  10. Eli

    Eli Senior member

    Yes! That is exactly the problem. It has to be named Sampler Instruments exactly and be at the root level inside the project folder.
     
  11. mrvinyl

    mrvinyl New Member

    Great I am finally there! thanks Eli :)


    ..........gone sampling
     

Share This Page