1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 EXS24 doesn't retain sample region edit

Discussion in 'Logic 9' started by sonnykeyes, Apr 4, 2012.

  1. sonnykeyes

    sonnykeyes Senior member

    Perhaps I've forgotten something basic, but I've been trying to edit an EXS24 patch of bicycle bells using samples from my SFX library, and no matter what I do, when I edit the sample to play from the beginning of the bell SFX, it always reverts back to playing the whole sample file, including the silent second at the beginning. I know I've done this a thousand times before, can you help remind me what I'm missing? Thanks!
  3. Eli

    Eli Senior member

    Just to rule out the obvious: Are you saving the instrument (or saving as) once you've modified the sample start? Because I don't think just modifying the instrument zone parameters and saving it within a project is enough to have it recalled correctly. You need to actually save (or save as) the actual EXS 24 instrument itself.
  4. sonnykeyes

    sonnykeyes Senior member

    Thanks Eli, yes, it's actually more pernicious than that: I double-click on the sample or zone to open up the sample editor, then I adjust the start and end points, then, even with the correct selection in the open sample editor, I can play a key and it still plays the whole sample. If I close the Sample Edit window, then next time I open it, the whole sample is selected again, and Saving or Saving As at any point during this process makes no difference. Eventually I got frustrated and saved the relevant regions as separate audio files to load into EXS24, but I shouldn't have to do that. Thanks anyway!
  5. Eli

    Eli Senior member

    Hmmm, not sure why this is happening. It' not a "zero crossings" thing, where the selection is snapping due to zero crossings being enabled is it?

    It's a long shot, but maybe the permissions on the EXS 24 instrument need to be altered? Are they factory instruments? It might not hurt to check the permissions on them and see if changing them influences the behavior.

    Other than that, I don't know what else might be causing it.

Share This Page