Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 EXS24 not loading all samples

Discussion in 'Logic 9' started by lcollen1, Nov 2, 2011.

  1. lcollen1

    lcollen1 New Member

    Since moving Logic Pro (v9.1.5) from a laptop with Snow Leopard to an iMac with Lion (10.7.2) my EXS24 will not load all samples/instruments. I’d say it will load roughly half of them. I’ve tried to take a look for any major discrepancies, but everything seems to be correct. Everything else is in it’s place and is working fine, it’s just the EXS that’s not working right. The list of instruments for it are right where they’re supposed to be App Supp.>Logic > Sampler Instr. (Or at least that’s where they had always been before.)
    I’ve gotten other plug-ins to sort of take their place, but I would still love to have them back. Is this a known problem? I ask that as a few other folks seem to be having a similar problem. What can I do to correct it?
     
  2.  
  3. Colin Shapiro

    Colin Shapiro Senior member

    Does your main drive perhaps have a different name now? (Default is Macintosh HD)

    EXS24 instruments store info (file paths) about where the related samples should be found. If anything is different from before, this can slow loads or files not found.
     
  4. georgelegeriii

    georgelegeriii Senior member

    I have experience on a number of occasions that the Logic installer seems to miss samples. Try and reinstall this part of the library again, and don't forget to check the older ones (it says something about compatibility in the server dialog) and forget to install the FX and music Apple Loops, otherwise it's gonna take quite a bit longer to do this.
     
  5. lcollen1

    lcollen1 New Member

    Thank you to both of you for the quick responses.
    Mr Shapiro:
    I'd thought at one point that something like that might be the problem, but if that's the case it doesn't really explain why the EXS is able to find one part of the library and not another. having said that I would still like to check it out, just where would I find and-possibly-be able to change that path?
    Mr. Leger:
    I've tried any number of times to reinstall the missing samples, but I always get a window that says that it can't find them. Although I can, very easily, find them apparently the program can't. So how else would suggest I accomplish this? (BTW I love Zappa also)
     
  6. georgelegeriii

    georgelegeriii Senior member

    Redmatica EXS manager is the only tool I can think of to do this, it costs $50. GREAT program, as is their others: http://www.redmatica.com/Redmatica/ExsManager.html

    Saw Mr. Z on Steve Vai's first tour with him, and then his last tour. Awesome shows, unbelievable band both times, and I wish he was still around.
     
  7. lcollen1

    lcollen1 New Member

    thanks
     
  8. Colin Shapiro

    Colin Shapiro Senior member

    If the file paths within .exs files are broken, you'll have to get Redmatica's EXSManager (or ProManager) (at redmatica.com). It's an essential app for anyone with large and/or 3rd party sample libraries. It quickly re-links all the instrument and sample files - which you could do one by one (very laborious and time-consuming) in EXS24 itself.

    If your file paths are unchanged from before, this problem shouldn't happen.

    Another thought:
    Did you also have iLife/Garageband installed? Also installed on the new iMac? Lots of instruments and samples come from there.....
     
  9. emetalhead

    emetalhead New Member

    How does one go about re-linking the instruments manually? One of my EXS24 instruments has strangely disappeared both from Logic and, seemingly, from my hard drive. Perhaps that would fix it?
     
  10. emetalhead

    emetalhead New Member

    never mind, i found it. it's still on the hard drive. it just won't load in Logic. "instrument not found" always pops up upon opening the project.
     
  11. moarts

    moarts New Member

    I have the same exact problem did you find a solution? I am absolutely baffled.
     
  12. lcollen1

    lcollen1 New Member

    I did actually, but it cost me. The problem was caused (and I don't know why) by the various sample libraries not being recognized by the transfer to my new computer or OS. The solution was to buy, as suggested, the program made by Redmatica called ProManager. With it you can reattach the sampler to the samples it's no longer able to see, but (in most cases) are still there.
    So the answer to your question is Yes, but then again NO!
     
  13. markfrancombe

    markfrancombe New Member

    I have a cheaper fix.. Same happened to me after going to Lion..
    I just re-installed Logic... everything... boring.. but free!
     

Share This Page