1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 8 External hardware & audio interface help

Discussion in 'Logic 8' started by kanedit, Oct 5, 2010.

  1. kanedit

    kanedit New Member

    Hi guys. I have two issues.

    I'm running Logic Studio 8 on a 10.5.8 OS. Using a Alesis Q49 controller, with an Access Virus C. I have an M-Audio Pre interface but this does not have midi in/out, so I have just gone out & got a Cakewalk UM-1G midi interface so I can record midi into Logic.

    I have installed the drivers for the new interface, set-up the UM-1G in the Audio Setup located in the Utilities, which is fine. I have then opened up the Environment in Logic and created a New Instrument & selected the UM-1G interface on the Inspector parameter...but for some reason it will not recognise or record into Logic on the arrange page (Problem no. 1). I can hear the sounds coming through on my monitors, and since I have installed the UM-1G interface, when ever I hit a note on the keyboard I hear like a metronome sound coming from my Mac, at the same time as what I can hear through my monitors (problem no. 2).

    Any help would be most appreciated.
     
  2.  
  3. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    Can you use the "Grab" utility to capture the environment setup for your "instrument" -- instruments can be single channel, or "multi" -- is your MIDI keyboard capable of sending MIDI/playing back multiple MIDI sounds on individual MIDI channels?

    It sounds like you have not selected the correct routing, or maybe you are transmitting on "All" MIDI channels. You also need to select the Audio Device you want to use for record/playback in "Audio-MIDI" setup. You may be configured to use the internal audio within your computer (for recording) instead of using your external audio interface.
     
  4. kanedit

    kanedit New Member

  5. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    It looks to me like the name of the multi-instrument you created should be your Access Virus C, not your UM-1G single port MIDI interface. Logic should already know about the MIDI interface because it is already recognized in the AUDIO-MIDI applet. So rename your MIDI multi-instrument to (or create a new Multi for...) your Access Virus C. You should then create a MIDI track, and select the Virus (once created, Multi-instruments will appear as a choice in the arrange window popup...) in the arrange window as your MIDI input device. That should let you record the MIDI. If you are not using the physical audio outputs of your Virus to monitor it, you could also create a software instrument track (and insert a piano/synth, etc), and then use your Virus to trigger it with MIDI.
     
  6. kanedit

    kanedit New Member

    What I ultimately want is to record audio from my Virus into Logic using the UM-1G interface.

    I can record midi notes in Logic from playing the Virus. But Im having trouble selecting the routing for the Virus to record audio onto an Audio channel, instead of using an instrument track to record midi notes.
     
  7. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    In that case, the MIDI setup is superfluous, unless you want to record the MIDI first (so you can edit it in the matrix or score editors, and then use the MIDI recording to play back the Virus synth).

    You need to route the audio output from the synth into your audio interface. After you create an audio track, assign your input so that wherever you plugged in your synth matches up with your selection. This assumes you have analog inputs in your interface. Then send your output to your monitors.

    It goes without saying that MIDI interfaces do not transmit audio, they only transmit the MIDI data. The MIDI data, once recorded, can be used to play back either the audio from your synth, or a software instrument. You do not need to use a MIDI interface if you are only interested in recording audio.
     
  8. kanedit

    kanedit New Member

    So I would need to purchase a cable that would go into my 'insert' on my mixing desk and route that to my M-Audio Pre Mobile interface? This would then record the audio into Logic right?
     
  9. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    I would go from your synth analog outputs with a 1/4" unbalanced cable direct into one or both of the XLR/TS combo jacks on the front of your MobilePre audio interface. Keep everything simple. You can integrate your mixing desk later. If you haven't already selected the MobilePre as your recording and playback interface in the "Audio" panel of the AudioMIDI applet, do that, too. (You uploaded the MIDI panel.)

    Then just create an audio track in the arrange window, and select your MobilePre's interface jacks, probably 1 and 2, etc.

    Depending on the output level of your synth, you would set up your MobilePre interface for either instrument level or line level input (not microphone level). You should not need a mixing board to just record the synth output. The inserts on your mixing board would let you run your synth into a compressor (or whatever) before reaching Logic, but you can also just take the out from your synth into a compressor, and then run the out from the compressor into the MobilePre. Unnecessary if you set your levels correctly.

    When I record a synth, I record-enable both an audio track and a MIDI track and record both together. You may need to enable "software monitoring" to hear yourself unless you use hardware monitoring (a good use of a mixing desk). Then I copy the MIDI onto a software instrument track to edit it, using the audio track as a guide.
     
  10. kanedit

    kanedit New Member

    I have taken the phono jack out of my mixer and inserted it into the Line Input (Channel 1) of my M-Audio Pre Mobile. But I'm still hitting a brick wall with regards to recording onto an audio track.

    The Mobile Pre is selected as the Core Audio input in the Preferences tab. I have now selected the 'software monitoring'. So where do I go now in terms of routing the virus sounds to an audio track?
     
  11. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    I assume you have plugged your synth into your mixer. Can you hear your synth's audio output through the mixer's headphone jack? And is the level of your synth set so it is moving the mixer's LEDs or VU meters without clipping?

    Here go three screen shots. The first is the audio pane from my AudioMIDI applet. On your computer, it should say your M-Audio device, on mine it says Eleven Rack.

    The second screen shot is the general audio preferences setup screen. Again, it shows my interface, not yours, but you may need to enable a checkbox there.

    The third screen shot is the create track pop-up you get from the Track -> new in the arrange window of Logic. This is where you select the input of your audio interface.

    If you can record MIDI, then you already know that tracks need to be "record-enabled" in addition to putting your transport into record mode.
     

    Attached Files:

  12. kanedit

    kanedit New Member

    Juan, thank you so much for the advice. I have eventually got there in the end with your help.

    This forum is much much better than the other Logic forum I have been using.

    Big thanks again Juan :D
     

Share This Page