1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Flex audio leaving random pops?

Discussion in 'Logic 9' started by daveyboy, Aug 1, 2009.

  1. daveyboy

    daveyboy Senior member

    I was using flex in polyphonic mode to fix an acoustic guitar track today. It worked great except that on playback I would sometimes get a pop near one of the fixed places. if stopped and restarted it would disappear. So, I thought if I merge it it'll "print" the flexed audio. Instead it committed the pop. Then I bounced in place. Same problem. Finally I bussed it out to a new audio track and recorded it in real time. I got a pop but i could stop and punch in. big pita. I didn't have a ton of flex edits on this particular track either. Any thoughts or work arounds? I know this is still all new and most likely this is another bug and will eventually get fixed.
  3. mmm42

    mmm42 Senior member

    The polyphonic one - if I remember correctly - is depended on the right transient markers, check if the transients are working for the material and adjust if necessary.
  4. daveyboy

    daveyboy Senior member

    I also tried other modes, tried deleting markers, etc. No luck. Seems like a bug.
  5. Bob Bickerton

    Bob Bickerton New Member

    Same here, random pops on monophonic bass line, variable dependent on playback start point and are recorded into merged or bounce in place audio. No plugs on channel.

  6. pjl

    pjl Member

    I haven't used Flex yet but I was wondering if this would be a problem. When they introduced this feature into Sonar a few years back I noticed the same thing which is apparently because they had to make the algorithms work fast enough not to hinder workflow and this meant lower quality. However, in Sonar they used different algorithms for bouncing and freezing off-line (Izotope Radius) so there were no pops in the final product.
  7. Bob Bickerton

    Bob Bickerton New Member

    Unfortunately, pops are written when bouncing.

  8. Alan Branch

    Alan Branch Logic Samurai

    your probably better off with slicing mode.
  9. daveyboy

    daveyboy Senior member

    Slicing mode sounds much worse. I like the way flex sounds. There are just these random pops which usually occur few beats prior where the "fixed" audio is.
  10. Petrosil

    Petrosil Member

    Two hints that may improve your results: For Slicing mode try to disable "Fill Gaps" and set "Decay" to Inf. in the Flex track inspector. When using Polyphonic mode try to enable "Complex" checkbox.

    So far I got good results with guitar using slicing mode, but I had Fill Gaps off and Decay set to Inf..


  11. daveyboy

    daveyboy Senior member

    thanks.I'll check that out. Still curious how I get pops where I'm not engaging any flexing. Does anyone know if one can "commit" the changes via a simple merge of the file or does one have to bounce it down. Either for me still leaves a pop.....but, in case I actually figure that out, I want to know if just merging it will effectively print the change.
  12. daveyboy

    daveyboy Senior member

    thanks.I'll check that out. Still curious how I get pops where I'm not engaging any flexing. Merging left a pop as did bouncing but, maybe I'll try creating a new audio file from region to see that is pristine.

Share This Page