1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Flex Graphics Bug?

Discussion in 'Logic 9' started by paulnajar, Mar 5, 2010.

  1. paulnajar

    paulnajar Senior member

    Start flex on a track with flex view turned on and as expected you see all the light grey transient markers on any audio regions.

    Then move some non Flexed audio on another track onto the first first flex enabled track. You'll see Logic analyse the transients and then... nothing. No flex view. The existing audio on the same track has flex view clearly displayed but not the new audio placed on the same track.

    Toggle flex off then on and all is well again. Hopefully not just my rig doing this...

    Folks?
     
  2.  
  3. Badger

    Badger Member

    I think you have to enable flex for the region you just moved in the inspector as well as the track
     
  4. paulnajar

    paulnajar Senior member

    I wish it were that simple. Flex is a track based function not a region based one.

    You can engage flex for all the regions on a track without any regions on that track actually being selected...

    PN
     
  5. Badger

    Badger Member

    In my understanding it's both. I had the same problem: when I turned flex on it still wasn't turning "on". Then I realized I had to enable a region to get it working. Try it.
     
  6. paulnajar

    paulnajar Senior member

    In the interests of accuracy I quote from the Logic 9 manual page 526.

    "Flex modes are track-based settings that determine how the audio will be altered"

    Thanks for trying to be helpful -but- Flex is track based. Really. You can't turn it on or off for individual regions. That's why it's a graphics bug.

    Kind regards
     
  7. Badger

    Badger Member

    [​IMG]

    Here's a screenshot of flex turned off for one region on a track. Have a look at the inspector on the left. That's when it started working for me once I looked there.
     
  8. Eli

    Eli Senior member

    Hi Paul,

    Badger is correct. There is a region based flex checkbox that allows you to specifically include/exclude certain regions on a track. By default Flex is track based, and is meant to be used that way. But this option is there to use, for example, to cut up a drum fill in a track and exclude it from flex so that it's not quantized. And other similar sorts of situations.

    I haven't checked (not in front of Logic at the moment), but it is possible that when you drag a region from another track onto a flex enabled track that the region parameter defaults to having flex mode disabled.

    Anyway, check in your region parameter box and see if that could be the source of the problem.
     
  9. paulnajar

    paulnajar Senior member

    My apologies Badger and thanks Eli. You are indeed correct. While I've not had the time to check it all looks like it will be correct.

    Strange that when you enable flex for a track ALL the regions on the track get their (region) flex box ticked even when the regions themselves are not selected, but when you drag new audio onto an already flex enabled track the default behaviour is to analyse transients but to leave the region flex box un ticked.

    As a very long time Logic user this behaviour seems counter intuitive to me.

    Thanks again guys...
     
  10. daveyboy

    daveyboy Senior member

    Also, check out Eli's Logic Flex videos over at Groove3.com (just rent them). So many great tips there.
     

Share This Page