1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 FW 1804 under 10.6.2

Discussion in 'Logic 9' started by Pita_Araujo, Nov 13, 2009.

  1. Pita_Araujo

    Pita_Araujo New Member

    My TASCAM FW 1804 is not being recognized by MAC OS 106.2
    Just after having updated it worked for a moment, and then died flat on the face.
    The interface is working OK. MIDI and Audio work OK
    Are there any driver uptades out there? Could'nt find nothing on TASCAM website.
    Help !! I'm in the middle of several projects
     
  2.  
  3. Pita_Araujo

    Pita_Araujo New Member

    Just like magic, after removing the driver with TASCAM's own utility and installing again from scratch, rebbot, repair permissions and…voilá…it's working
     
  4. Janne

    Janne Member

    Tascam basically killed all (Mac) support of these units, 1804, 1884 & 1082, some years ago...
    There are serious known bugs in the drivers that were reported to Tascam over two years ago that they have intentionally ignored.

    After being lied to several time over a period of 12 months by Tascams representative, I ditched my FW-1082 for a Focusrite Pro 40 and I can't, ever, see my selves put money in another Tascam product...

    If You can use it on 10.6.x, great! But don't expect any updates from Tascam...
    (Frontier Design who wrote the drivers for Tascam did a great job, the drivers themselves have been functional over several OS updates without breaking, since 10.3 if I remember correctly)
     

Share This Page