1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Help Me Imported Click Track Doesn't Match Project Tempo

Discussion in 'Logic 9' started by JLonderee, Mar 26, 2010.

  1. JLonderee

    JLonderee New Member

    I use a Zoom-234 with a metronome preset set to 60 BPM for a click track, and record it down as audio To an Alesis HD24 during the tracking session.

    I import the project to Logic and set the project tempo to 60 BPM, thinking that this will make the background grid match my audio click track, and therefore the tempo of the recorded audio tracks, as the audio was played reasonably tight to the click track.

    I want the grid to match the tempo of the click track, but this does not happen.

    The grid matches the click track closely for a few bars, then they drift apart slowly, until around the end of the song its way off.

    I used the bmp counter on the click track which gave me a result of 117.3.

    This seems like a simple operation, what am I doing wrong? how can I get around this?
     
  2.  
  3. Peter Ostry

    Peter Ostry Administrator Staff Member

    Your rhythm machine and your Mac are not synchronized, they do not use the same time base. Therefore their tempo will never be exactly the same. You gonna use the recorded click, so you have to set the tempo in Logic.

    Import your tracks, go to the first visible upbeat in the recorded click track. Zoom fully in and cut the region where the click begins:

    [​IMG]

    Do the same after a couple of bars, let's say 4 or eight or more, the more the better.

    Move all tracks, so that the first click (where you cutted the region) is precisely at a Logic bar. It does not matter which bar it is.

    Then make a cycle range to match the bar count of the click track. In the example below I took 4 bars of the click track, so I made the cycle 4 bars long. You see a big difference between the Logic timeline and the recorded click:

    [​IMG]

    Activate the region and from the main menu, select
    Options –> Tempo –> Adjust Tempo using Region Length and Locators

    [​IMG]

    Logic asks you if you want to set the tempo globally, say yes.

    After that, Logic adapts the global tempo to the length of the region and this is what you need:

    [​IMG]
     
  4. JLonderee

    JLonderee New Member

    Peter, thank you so much! That was just what I needed!
     
  5. Jay Asher

    Jay Asher Senior member

    OR, you could use Strip Silence and with Flex, quantize the Audio., therefore keeping your present tempo.
     
  6. Peter Ostry

    Peter Ostry Administrator Staff Member

    I think he wants to keep the recorded music as it is. His Logic arrangement may be empty when he brings the tracks in. He recorded the click during the performance to have a reference for post production, but the click did not fit. At least this is what I understood.
     
  7. JLonderee

    JLonderee New Member

    That is correct, Peter had it right.

    Got another issue, tho. Same production.

    Used autotune to edit a vocal.
    Bounced the tuned vocal.
    Turned on flex time -monophonic to edit the timing of the vocal performance

    The region for the vocal is now twice the size and plays at half speed.

    ?
     

Share This Page