1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Help: no grab and drag

Discussion in 'Logic 9' started by Beatlefreek, Apr 14, 2013.

  1. Beatlefreek

    Beatlefreek Member

    This is just happening on one song, so I must have hit or flipped some switch to create this problem on this particular tune. But I don't know where to look to fix things.

    The problem is that I want to move some inserts on one channel over to another (not copy and paste, just move an insert from, say track 1 over to the same slot in track 2), but the cursor won't grab and drag it (ie: the little "hand grab" icon doesn't appear).

    All help will be much appreciated. Thanks.
  3. Eli

    Eli Senior member

    You need to hold down the command key to select the alternate tool to get the hand tool. Normally in the Track Mixer there is only one alternate tool, so there's not really much that can go wrong. It can't get reassigned accidentally since there is nothing to reassign it to!

    Is it possible you are using the Environment mixer and not the Track Mixer??

    What tool does come up when you hold down the Command key?
  4. Beatlefreek

    Beatlefreek Member

    I do hold down the Command key, but when I move the cursor over the insert I want to move, no little "hand grab" icon appears, making moving the insert impossible.

    Also, I am in the track mixer window.

    And I repeat, I am doing exactly the same thing (same procedure) for all the other songs I'm working on and the insert grab & drag works perfectly fine. So something in this song must be either turned off, or some other (inadvertently) selected command has been hit that is over-riding the grab & drag.
  5. Eli

    Eli Senior member

    What alternate tool _do_ you see when you hold down the command key? Are you seeing nothing except the regular pointer tool when the Command key is held down?
  6. Beatlefreek

    Beatlefreek Member

    There is no alternate tool that appears. The only thing I see when I hold down the command key is the normal arrowhead cursor. The hand grab icon should appear but doesn't.
  7. Eli

    Eli Senior member

    Try re-assigning the alternate tool to the hand tool. Maybe somehow you have the pointer tool assigned to both.

    Look in the upper right of the Track Mixer and verify that the alternate tool is assigned to the hand tool.

    See the screenshot below.

    Attached Files:

  8. Beatlefreek

    Beatlefreek Member

    Ohhhh. I see what the problem is now!
    Your question prompted me to check the setting on a different song, a song where the grab is working.
    In the upper right hand corner of the track mixer window, in the two little side by side cursor select windows, in the "normal" position, the left window should have the regular arrowhead cursor appearing, and the right window should have the hand grab cursor appearing.
    In that configuration, when you hold down the Command key and hit the mouse, the hand grab cursor will appear over the insert you want to move.
    Every song I checked, that arrowhead right/hand grab left was the set up. The problem song had both of those little windows showing arrowheads.
    I made the switch and it all works perfectly fine now.
  9. Beatlefreek

    Beatlefreek Member

    LOL! That's exactly what it was! Thanks, Eli.
    Your solution came in just as I hit send on my above reply.
  10. Beatlefreek

    Beatlefreek Member

    But that just goes to show that my original intuition — that I must have hit something accidentally (but didn't have a clue as to where to look) — was correct.
    Thanks again for hangin' in there to help me with this.
  11. Eli

    Eli Senior member

    Glad it's solved! Switch the tool, and all will be fine.

Share This Page