1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Hosa Tracklink Midi to USB Problem

Discussion in 'Logic 9' started by Justus1199, Nov 17, 2010.

  1. Justus1199

    Justus1199 New Member

    Hello folks.

    I'm trying to use my Roland EP-7 II as a MIDI controller for Logic Express and garage band. I have a Hosa Tracklink Midi to USB running to my iMac. The keyboard triggers the proper note and velocity for single notes, but when ever I play more than one note simultaneously they sustain infinitely and can't be turned off (clicking play/pause shuts them down)

    I've looked around on line and found several how-to's that talk about setting up the utilities>audio MIDI setup>select your midi device ect but neither the Roland or the Hosa MIDI interface show up in the Audio Devices window.

    My TonePort UX2 shows up...

    This happens in Garageband too.

    Hosa doesn't offer any drivers for the Tracklink cables it's supposed to be "Plug and play"

    Is this the MIDI interface? Logic setting? MIDI setting?

    If it's the cable please recommend a better MIDI to USB interface.

    Thanks for your help.

    -Justus
     
  2.  
  3. Justus1199

    Justus1199 New Member

    After checking all my settings and trying to download drivers for the Hosa cable I gave up and ordered a new MIDI interface (The MIDISPORT Uno from M-Audio)

    I downloaded the updated driver from M-Audio's site, plugged in the interface and it works perfectly. I guess Hosa's cable is just not as 'plug and play" as they advertise, and they do not offer any driver support for that model on their site. Though it says it's Mac compatible, maybe it only works on PC...
    -Justus
     

Share This Page