1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to use Casio sounds within Logic

Discussion in 'Music Creation' started by designjh, Jun 24, 2009.

  1. designjh

    designjh New Member

    I am new to Logic Pro. I can get my Casio WK-3500 to record MIDI to Logic and I can get Logic to play Casio sounds through the keyboard. How do I get the sounds from the keyboard to play through my system without coming back out of the keyboard? In other words... How do you get Logic to record the sounds from my keyboard to play without the keyboard always being hooked up? I want the Casio sounds in my recorded music for saving to disk.
     
  2.  
  3. Eli

    Eli Senior member

    Plug the outputs of your Casio synth into your audio interface, and record them as audio tracks in Logic.
     
  4. designjh

    designjh New Member

    Thanks for the reply. I am using a Casio keyboard as MIDI/instrument and a Fireone for my input to Logic. When I record a instrument track the notes come through and I can change it to a Audio track but I then have to add sounds. If I leave it as a instrument track there is no sound. If I bring it in as a MIDI then the Casio sounds are only played back through the keyboard but not through my speakers like everything else. I can not record the keyboard on an audio track. Is there a way to do this? Some special set-up. In following the book info it doesn't give me this option that I have found. Thanks again.
     
  5. Eli

    Eli Senior member

    * Cable the audio outputs of your casio synth into your Fireone interface.

    * Solo your midi track that is triggering the casio synth.

    * Create a new audio track.

    * Set it's input to correspond to the input receiving signal from your casio synth.

    * Record enable the audio track.

    * Play the sequence and adjust the input level on your Fireone so the signal is at a good level.

    * Record. The audio output from the casio synth will now be recorded onto the audio track.
     
  6. designjh

    designjh New Member

    Thanks again Eli.

    I have cabled my outputs to the Casio into the Fireone interface.
    Then I recorded a GM device1 track using the sound I wanted from the Casio synth.
    When played back, this GM1 track sounds through the Casio correctly.
    Then I Solo the GM1 track by using the yellow "s" button.
    I then created a new Audio track. (What input do I use? I used input 1)I highlighted the audio monitoring and the record enable.
    When this track appeared the red "R" is highlighted.
    I prepared the fireone for good input levels.
    I then pushed record and a blank line was recorded. No matter what I did with the fireone it didnt affect it. So I am guessing that I don't have the correct inputs to the casio synth.

    How/where do I find out what the Casio Synth input is? I can find the Audio input in the mixer and the environment windows.

    Thanks again.

    John
     
  7. Eli

    Eli Senior member

    The problem has probably got to do with being in solo mode. I suggested you solo the region so that other Casio MIDI tracks won't play through the Casio at the same time and get recorded together with the track you want.

    So, in case it is the only track triggering the Casio, never mind about using solo mode. If you are triggering multiple Casio tracks and just want to record the one. Then do use solo mode. But you have to make sure the region is selected while in solo mode.

    It sounds like maybe after record enabling the audio track, you may have lost your selection. So, just make sure the proper MIDI track is selected when in solo mode and you hit record.
     

Share This Page