1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 how to use multiple cpu cores

Discussion in 'Logic 9' started by seffro, Jan 24, 2013.

  1. seffro

    seffro New Member

    The cpu meter shows all 8 cores but only one gets used and is almost maxed out. Its a project with 24 inputs and 8 headphone mixes using software monitoring. I am wondering if theres a way to make Logic spread the workload over all the cores so I can have mega low latency when tracking.

    09 mac pro 2.66 quad
    24 gb ram
    pcie 424 motu 24 io
  3. Markdvc

    Markdvc Administrator Staff Member

    Yes, there is an Apple KB article dealing with the issue of spreading the CPU load on multicore systems.

    I note that you are new both to the LUG and Logic - welcome!

    May I suggest you go to our FAQs, which are here:


    The article I referred to is linked from Logic 8 FAQ #15

    Additionally, in Logic 9's audio preferences you will find a setting, processing threads, which allows Logic to access some or all of the cores present. Try experimenting with different settings. FWIW, on my 8 Core Mac Pro, I leave this set to Auto.

    Feel free to browse through the other L8 and L9 FAQs - hopefully there will be some helpful tips for you in there.

    kind regards

  4. seffro

    seffro New Member

    Thanks Mark, I am new I just switched to Logic and so far Im loving it
  5. georgelegeriii

    georgelegeriii Senior member

    The problem is the amount of Live inputs you have going. Logic can only use one core for all live inputs, tracks that use busses or inputs.

    Tracks that will spread to more than 1 core are instruments that are not selected in the arrange window (any selected track in the arrange window becomes a live input), recorded audio tracks, and the insert effects being used by them (which would be a good reason to use insert effects rather than busses I suppose).
  6. seffro

    seffro New Member

    Very helpful thanks
  7. Tangra

    Tangra Senior member

    Here is an Apple article direct LINK which shows that in details inc image schemes etc.
  8. smicloud

    smicloud New Member

    I know this is an old thread but it comes high up in google so for other user who have had this issue, here is my problem and solution:

    1. Open the mixer ("X")
    2. "I" were selected for all tracks here even though they were not selected in the tracks area.
    3. Unmark those
    4. After this, the load were distributed nicely over all CPUS/Cores and all crackling had disappear.

    Hope it helps someone so you don't have to sit in support with Apple for 1.5-2 month without any other solution than getting a link to online tutorials at the end...

Share This Page