Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Issues with controller assignments and Parameter Learn

Discussion in 'Audio Units: Effect and Instrument Plugins' started by thmusic7, Mar 12, 2016.

  1. thmusic7

    thmusic7 New Member

    Hi. I am using a Nektar Impact midi controller with knobs and faders to learn parameters using third party plugins. Here is the problem I'm having

    I select the parameter I want to learn, such as vibrato, or reverb amt. I press Command L on my Mac, and the controller assignments window comes up. I then turn a knob or fader. It works for some of the Kontakt plugins such as Studio Drummer or Giant, but it doesn't work for others such as Spitfire Audio, Galaxy Pianos and Omnisphere 2.0. Below is a pic of what the format it looks like when the parameter learn works with The Giant. The other pic shows that the Parameter change doesn't work with Spitfire Audio. Any feedback or advice would be appreciated friends. Thanks in advance.

    Running Logic X on a 2010 iMac upgraded to El Captain 10.11.2 and using a Nektar Impact Midi Controller
     

    Attached Files:

  2.  
  3. thmusic7

    thmusic7 New Member

    Hi. Anyone found any answers yet?
     
  4. Peter Ostry

    Peter Ostry Administrator Staff Member

    No great ideas yet.
    According to the screenshot, Logic says "No message received", that's it.

    Is it true? You may install Midi Monitor and check if there is really no valid message.
     
  5. thmusic7

    thmusic7 New Member

    Ok thanks. I'll check it out.
     

Share This Page