Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Issues With Copying Parts of Tracks

Discussion in 'Logic 9' started by JohnnyYenAgain, Nov 20, 2011.

  1. JohnnyYenAgain

    JohnnyYenAgain New Member

    Hi All-First time post for me. I'm looking forward to spending more time here considering I'm new to Logic and home recording. Also, my apologies if this issue is covered elswhere.

    I'm currently using Logic 9.1.5 (1700.9) 32 bit on my iMac 10.6.8.

    So, I'm recording horn parts on three different tracks and because I'm using the same part throughout the composition I'm recording one three second part, recording octaves for this small part on two other tracks, and then trying to cut and paste these three parts in various places throughout the same three channels.

    What is happening is that when I select the three parts on three seperate channels, hold the option key down, and drag them to a new position, the tracks don't go to this new position but to a place right before where they originally resided. They seem to be unwilling to go to where I drag them to. I've tried doing this to one track at a time and the same thing happens.

    Any idea of what is going on here? Do I have a setting that is dictating this that I am unaware of.

    Any help is appreciated.

    Best,

    JYA
     
  2.  
  3. JuanTahnahmahrah

    JuanTahnahmahrah Senior member

    Hey, Johnny..welcome to the forum.

    Instead of dragging your parts, select them, use the copy command, click on the time-line where you want to insert them, and then use the paste command.

    You should consider going through a few tutorials. Logic has a lot of shortcuts, and after more than five years, I still do not know all of them.

    I use the "paste at original position" menu selection when I want to make a copy at the same time-line position. And there are likely several "snap" functions that can affect where your region lands if you are slipping it into place.
     
  4. JohnnyYenAgain

    JohnnyYenAgain New Member

    Issues With Copying tracks

    Thank you for the quick reply. I'm heading out the door for a five day trip and will try your idea when I return. Thanks again for the advice and the good chuckle at the log in name! Best JYA
     
  5. georgelegeriii

    georgelegeriii Senior member

    There is also a preference in the Logic prefs that is "limit dragging to one way" or something close to that (don't have logic open right now). Check this and when you drag a region it can only move up or down OR side to side when being dragged or copied.
    I suspect that is what you want.

    If you do go the copy/paste method, be sure your playhead is at the location you wish to paste the tracks, or else they will end up in the wrong place.
     
  6. Doug Zangar

    Doug Zangar Senior member

    I think you have a Drag mode setting that's wrong. Sounds like it's set to Shuffle Right. Change it to one of the first three settings, depending on the way you work.

    I use the Option drag for copy all the time, it should work fine with the correct Drag mode setting.
     
  7. Eli

    Eli Senior member

    Just to add to what Doug said, make sure your snap value is set appropriately also. If it is set to "beat" or "division" or something like that, it will restrict and quantize your movements.

    If you do have/want it set that way, use the control key or control and shift keys while option dragging in order to get finer resolution.
     

Share This Page