Combo Remapper - use score text and symbols to switch articulations
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Key cmds work once, then screen flashes instead?

Discussion in 'Logic 9' started by xmiinc, Feb 26, 2011.

  1. xmiinc

    xmiinc Member

    Logic newbie here, while following some video tuts on logic, I try out key commands, which seem to work once or twice, but thereafter my entire screen surface (dual monitors) does a quick fade to white and back in response. For instance, hitting '0' to relocate to start gives me this flash-fade effect instead of relocating. I thought it was a system thing, maybe Quickeys, Assistive Devices (on), etc, but I can't get the behavior back to normal. I did a quick search here, but didn't find anything relevant so far...

    Thoughts?
     
  2.  
  3. Doug Zangar

    Doug Zangar Senior member

    Could be a key focus issue. Depending on which window in Logic has the key focus, key commands may not work, or work unexpectedly. In Logic 9, the screen flashes when you ask it to do something it can't - perhaps that's what you're experiencing?
     
  4. xmiinc

    xmiinc Member

    yeh, that's what I thought too--focus issue--but I've made sure I'm in Logic and have what I think is the proper window element focused...say, Arrange window for hitting '0' to relocate. Still no love.
     
  5. xmiinc

    xmiinc Member

    Found it. Discovered the Key Commands prefs and did Options>Presets and reinitialized with 'US kybd with numeric keypad'. Problem solved. Thanks for your time and response, Doug!
     
  6. Doug Zangar

    Doug Zangar Senior member

    The window with key focus has the white halo around it. You can move it from window to window with the tab key (or shift tab to go counter-clockwise). Might just verify that's the case.

    Otherwise, brighter minds must contribute....
     
  7. Doug Zangar

    Doug Zangar Senior member

    Ha - missed your reply by a minute - welcome for responses - don't think they helped, however.......and thanks for posting fix - that helps everyone.
     
  8. David51

    David51 Senior member

    How did you do that?


    Hi, I'm having the same flashes when using key commands in the score editor. You wrote that you discovered the "Key Commands Pref", did you have to trash it for Logic to make a new one that worked without the flashes?

    Dooug? anyone?
     
  9. xmiinc

    xmiinc Member

    I meant the prefs pane, not the file. opt-K, there I applied the appropriate keyboard, and I don't have failing key combos anymore (where I'm not supposed to, that is). Hth?
     
  10. David51

    David51 Senior member

    Thanks Doug and xmiinc. I have to admit to some embarrassing mistakes-I reversed the shift and ctrl modifiers in my head and should have noticed, sorry. I do still get a flash of white light when using these though. That might be from the medication I'm on.
     

Share This Page