Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic 9 Lag....!

Discussion in 'Logic 9' started by Sparkle22, Feb 5, 2015.

  1. Sparkle22

    Sparkle22 New Member

    (My next post, straight on from the last...)



    Is there any reason (that I've missed) that is causing really annoying lag in Logic Pro 9? Are there any settings that I should check off?

    When I'm flying about the screen at speed - there is a progressively worsening lag on all click operations.

    For example, when punching up the toolbox (a right-click operation for me) it takes an infuriating half second for the mouse to react to the changes. If I select a eraser - it's always a split second behind and selects something else above the eraser as it hasn't caught up with my key strokes. The problem gets worse as the arrange window fills with audio gubbins and plugs.

    The really annoying thing is that my computer is relatively new and powerful.
    Macbook Pro, not solid drive, Dual Intel 2.3 i7s, 8gig RAM etc. running through Focusrite Pro24 - and I'm not exactly running 180 tracks of audio - maybe 25 at most and 15 synths/samplers.

    I'm running Log Pro 9.1.8 32bit.

    The other really annoying thing is that one of my old studio lappys was a little Macbook powered by steam, with only 3gig RAM, dual 1.87s first generation Intels - and it never did this. Granted I can run hundreds more soft synths and Space Designers etc on the new machine with barely a peep out of the CPU load meter - but it lags on the most basic of things - the mouse operations. It really slows my workflow.

    I've also noticed that the old 'spinning beach ball of death' is quite prevalent when opening the most basic of finder windows: Applications etc - it takes a several seconds to realise what I want to do and spins the little freakin' ball.
    SO annoying.
    The old machine never did this - and it was full of all kinds of junk - the new machine is music-only and has had its permissions validated many times.

    Is there some magic check box that I'm not aware of? Some OS/Logic update? An incompatibly issue with the sound card?

    Thanks.
     
  2.  
  3. Michael F Clef

    Michael F Clef New Member

    Do you store/open/work your projects from an external drive? My macbook sped up my logic workflow a lot since I've been doing that.
     
  4. Sparkle22

    Sparkle22 New Member

    Yes, that has occurred to me.
    I do stream from an ex-drive. But, my old dinosaur laptop never had a problem with the same setup. And it's not just Logic, as I explained.
    Just opening the Applications Finder window - the little beach ball of death spins (not every time but often enough) as it decides what is in my folder. Again, my little macbook never did that.

    I did a experiment yesterday on a large job in Logic. The problem wasn't in evidence as I started, but as the arrange page filled the response time got slower and slower. At one point, I was mousing over the toolbox - up and down, up and down - the reaction time was nearly a whole 3 seconds for the mouse to settle on my selection! That is unforgivable with this power of machine and also, I believe nothing to do with external drives.

    (I'm not going to start on my global conspiracy theory about how our computers, among other things, are being downgraded to so as to up our consumption rate of the said hardware to keep up with what we expect... lol. . .)
     
  5. Michael F Clef

    Michael F Clef New Member

    Upping to 16 gig Ram helped a great deal too. And I would tend to agree with your conspiracy theory. I even heard that the spinning beach ball of death is a symbol being adopted by the Illuminati.
     
  6. Sparkle22

    Sparkle22 New Member

     
  7. eartoyz

    eartoyz Member

    Did you ever find a solution to this problem? I am having the same issue and I am on a new Mac Pro 3.5 6 core with 32gb of ram, with both logic 9 and X.
     
  8. Sparkle22

    Sparkle22 New Member

    Sorry to hear that. It's maddening with the new machines, right?

    No solution yet, but I'm going to start narrowing it down.

    First: I will load all the audio onto the host drive and stream internally instead of from the ex-drive.

    Second: I will try a different sound card. I am using a Focusrite Scarlett Pro 24 DSP ATM - but my old 'travel' set up used a little PreSonus thingy which never gave me any problems.
    Then I will load it all onto my old macbook and see if that reacts the same way.. .
     
  9. eartoyz

    eartoyz Member

    I thought of trying the output of the computer without an interface altogether, I am using a UAD Apollo, but had similar problem with Apogee Ensemble.
    I ws given Applecare with my new MacPro so I have Pro Apps division trying to help resolve it and will let you know if they come up with a fix.

    Best!
     
  10. bayswater

    bayswater Senior member

    Have you set OS X to NOT let your hard drives spin down? Also have to be aware that some external 3rd party drives will ignore these settings and spin down anyway. A real PITA for sure. Everytime you do something that requires access to any drive, if any of them are idle, you often have to wait for all of them to get up to speed.

    It's worth googling the issue. There are terminal commands that will manage this for some drives.
     
  11. eartoyz

    eartoyz Member

    That makes perfect sense! When I moved to the newest Mac Pro I had to take the four drive-in my old Mac Pro and put them in an external case, I'm using a Other World Computing Thunderbay IV, I do occasionally put some to sleep if I'm not doing music production, but I haven't ever noticed them going to sleep on there on. I definitely have OS set to not let them sleep. However I experience this lag while working on a song for a bit, for the first 15-30 minutes everything will be fine,then I can try to move a fader or relocate to a different part of the song , or zoom,and it just does nothing. Then 10 seconds later it does everything I had attempted in a matter of seconds. I was having this same issue on my older Mac Pro, that's one of the reasons I got a newer one. I also did not migrate anything and installed logic from app store. Thanks for your help!
     
  12. Sparkle22

    Sparkle22 New Member

    Hey - - well after extensive testing (moving source audio to host drive etc - made no difference) and following the suggestions to do with HD spin down etc - I found that simply by increasing buffer size and buffer range more or less cured the problem. It's the ol' decrease buffers on input, increase when mixing.

    It's a little disappointing because I thought that I would (almost) never have to do that with this spec of machine. As I said at the beginning - this mac is not top of the range, but not far off it - and I'm not busting the bank with hundreds of plugs either. Our other studio machine is similar spec (desk top) and I can't recall having the same issues to the same degree...

    Well, I think a RAM boost will go a long way to help too (I currently have 8g).



    ......I'm still casting suspicious and slightly aggrieved looks towards Apple and their new line of machines........ hm. . .
     
  13. eartoyz

    eartoyz Member

    I am no longer having slow down issue with Mac Pro late 2013 and Logic 10.1. I have experienced it in Logic 9 however. Applecare no longer supports Logic 9 of course, so who knows if or when this problem may be addressed?
     

Share This Page