Sample Aid
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic X Limiting Piano Roll Movement

Discussion in 'Logic Pro X' started by VertuStudio, Jun 14, 2016.

  1. VertuStudio

    VertuStudio New Member

    There must be a way to do this:

    1.) Double-click a region; piano roll opens; the contents of the region are now right in front of me for editing; so far so good.

    2.) Key to a marker; now the piano roll view shifts to the start of the marker, ***even with the link button turned off***. In fact, the Link button turns itself on when I key to any marker. I tried messing with the Catch prefs but this didn't work.

    I want to be able to go from marker to marker while keeping the notes I want in front of me for editing.

    Is this possible?

    Thanks!

    Mike
     
  2.  
  3. volovicg

    volovicg Senior member

    See image below for desired behavior? is that what you want? As i move from marker to marker, piano roll view does not change.
    1/ Disable content link
    2/ right click on catch in the piano roll and disable all three catch modes
    3/ disable catch in the piano roll (turn blue off)

    If you have trouble - do the same thing for the arrange window - then once it works go back into the arrange window and turn back on what you need. If catch turn back on immediately after you have disabled it when you go to a marker. Deselect catch again.... there may be an issue where the first time you turn it off it does not take affect, but the second time it does.


    I am using the option + / key command to go to marker.....
    Also I am using 10.2.3




    marker catch.gif
     
  4. VertuStudio

    VertuStudio New Member

    Thanks! Disabling Catch Mode did the trick. Problem solved. Excellent video! :)
     

Share This Page